Recent

Author Topic: IDE not responding after start, obviously caught in an endless loop?  (Read 1887 times)

HappyLazaruser

  • Newbie
  • Posts: 1
After starting lazarus (either via a project's *.lpr or the icon on the desktop), the IDE
appears as expected but would not react upon any interaction (all menues except 'file' disappear upon the first click).

A check with the Process Monitor revealed that it seems stuck in an endless loop calling

IRP_MJ_CREATE C:\(mytempdir)    --> SUCCESS
IRP_MJ_DIRECTORY_CONTROL C:\(mytempdir)\LazarusMain01-*   --> NO SUCH FILE
IRP_MJ_CLEANUP C:\(mytempdir)   --> SUCCESS
IRP_MJ_CLOSE C:\(mytempdir)   --> SUCCESS

these four lines reappear and reappear and reappear .... (taking ~0.04s)

checking (mytempdir) manually: the requestes file exists, but with 0 bytes and locked. After killing Lazarus (necessary, it would not react upon close), I can delete the file (i.e., not locked any longer).

what I tried so far:
* another project --> same
* reinstall Lazarus --> same

OS: WIN 10 home
Laz 1.8.4 
FPC 3.0.4

Seems the access to the temp-file is broken. Any ideas what has gone wrong or what to try next?

Ñuño_Martínez

  • Hero Member
  • *****
  • Posts: 833
    • Burdjia
Re: IDE not responding after start, obviously caught in an endless loop?
« Reply #1 on: October 15, 2018, 11:17:35 am »
May be Windows10 introduces some new behavior about temp files or something and Lazarus/FPC doesn't use WinAPI correctly?

BTW I've noted similar behavior when creating my own configuration files in the configuration directory returned by GetAppConfigDir/GetAppConfigFile (I need to do some tests yet to be sure there's an issue): FPC creates it but with "read-only" permissions.  %)
Are you interested in game programming? Join the Pascal Game Development community!
Also visit the Game Development Portal