* * *

Author Topic: I really need help here -- PLEASE  (Read 801 times)

KarenT

  • Full Member
  • ***
  • Posts: 107
I really need help here -- PLEASE
« on: September 10, 2018, 10:30:27 pm »
I posted yesterday about the LazSerial error saying "Cancel loading this component" but things are worse.

In the IDE, when I click on some of tabs (not all) in the Source Editor then F12, I am getting another error message (quoted below) that has three buttons,
"Cancel'
"install this component"
"carry on without installing."

I click "Install these packages," even though I know the package is installed. It rebuilds everything and just goes around again. This is critical as I cannot swap from the code to the display (F12). The "Cancel" and "carry on..." options do nothing.


Quote
Probably you need to install some packages before continuing.

Warning:
The project uses the following design time packages, which might be needed to open the form in the designer. If you continue, you might get errors about missing components and the form loading will probably create very unpleasant results.

It is recommended to cancel and install these packages first.

 unit LazSerial in package LazSerialPort 0.2

taazz

  • Hero Member
  • *****
  • Posts: 5344
Re: I really need help here -- PLEASE
« Reply #1 on: September 10, 2018, 11:17:45 pm »
I posted yesterday about the LazSerial error saying "Cancel loading this component" but things are worse.

In the IDE, when I click on some of tabs (not all) in the Source Editor then F12, I am getting another error message (quoted below) that has three buttons,
"Cancel'
"install this component"
"carry on without installing."

I click "Install these packages," even though I know the package is installed. It rebuilds everything and just goes around again. This is critical as I cannot swap from the code to the display (F12). The "Cancel" and "carry on..." options do nothing.


Quote
Probably you need to install some packages before continuing.

Warning:
The project uses the following design time packages, which might be needed to open the form in the designer. If you continue, you might get errors about missing components and the form loading will probably create very unpleasant results.

It is recommended to cancel and install these packages first.

 unit LazSerial in package LazSerialPort 0.2
You need to identify those controls and the package they belong to. Uninstall it completely, rebuild the IDE, open your project and make sure that the IDE complains about unknown components. It will ask you to create a dummy package. On that question you answer no. Close the problematic project by starting a new one, do not save at this point it might delete those unknown component from your lfm. Now you have the names of the components find the package they belong to, use the opm to download and install that package, make sure that you install the proper package and not an empty representation of the original package.

As far as I remember the IDE does not offer to install missing packages only to replace them with empty ones.
« Last Edit: September 10, 2018, 11:19:49 pm by taazz »
Good judgement is the result of experience … Experience is the result of bad judgement.

OS : Windows 7 64 bit
Laz: Lazarus 1.4.4 FPC 2.6.4 i386-win32-win32/win64

KarenT

  • Full Member
  • ***
  • Posts: 107
Re: I really need help here -- PLEASE
« Reply #2 on: September 12, 2018, 12:43:56 am »
Thanks, but I un-installed 1.8.4 and installed 1.8.2 and the problem went away.

Time to make the change to C++ as I have had it with Lazarus. Way too many bugs and weirdness.

SymbolicFrank

  • Sr. Member
  • ****
  • Posts: 394
Re: I really need help here -- PLEASE
« Reply #3 on: September 14, 2018, 11:55:43 am »
Time to make the change to C++ as I have had it with Lazarus. Way too many bugs and weirdness.

Interesting comment. Object Pascal is far more logical and robust than C++. Then again, most programming languages are ;)

Trenatos

  • Sr. Member
  • ****
  • Posts: 442
  • Software developer - Open source contributor
    • MarcusFernstrom.com
Re: I really need help here -- PLEASE
« Reply #4 on: September 14, 2018, 03:53:03 pm »
Object Pascal <> Lazarus

I've found Lazarus to have bugs and whatnot, usually resolved pretty quickly, but the Object Pascal language is very nice to work with.

You're mixing up the tool with the language, it's like saying that you're done with Java because the Eclipse IDE is buggy.

Lazarus is an IDE, design tool, build-tool, and about a million more things, all wrapped  up in one.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus