* * *

Author Topic: rx components failing to install on linux 64  (Read 996 times)

liewald

  • Full Member
  • ***
  • Posts: 114
rx components failing to install on linux 64
« on: July 10, 2018, 12:18:21 pm »


Lazarus 1.8.2 r57375 FPC 3.0.4 x86_64-linux-gtk2

Components are failing to install with errors in the dbutils unit as follow :

Compile package rxnew 1.1.5.98: Exit code 256, Errors: 3, Hints: 2
dbutils.pas(239,3) Note: Local variable "SaveCursor" not used
dbutils.pas(34,30) Hint: Parameter "Field" not used
dbutils.pas(402,26) Error: Incompatible types: got "TBytes" expected "AnsiString"
dbutils.pas(413,64) Error: Incompatible type for arg no. 1: Got "PChar", expected "TBytes"
dbutils.pas(414,39) Error: Incompatible type for arg no. 1: Got "AnsiString", expected "TBytes"

Downloaded latest version still same problems

Thaddy

  • Hero Member
  • *****
  • Posts: 6754
Re: rx components failing to install on linux 64
« Reply #1 on: July 10, 2018, 12:26:39 pm »
From what I can see 1.8.2. is too old.  fpc 3.0.4. fcl-db has changed to tbytes from pansichar/ansistring so these messages are to be expected.
Ada's daddy wrote this:"Fools are my theme, let satire be my song."

wp

  • Hero Member
  • *****
  • Posts: 4916
Re: rx components failing to install on linux 64
« Reply #2 on: July 10, 2018, 12:34:14 pm »
But fcl-db belongs to fpc, and this has version 3.0.4 in both cases.

liewald, as I wrote in the sourceforge report, did you test a newer version? Your rxnew 1.1.5.98 is dated 2007! The current trunk version is 3.2.1.210. This version compile fines under Linux/Mint and Win10.
« Last Edit: July 10, 2018, 12:38:46 pm by wp »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

liewald

  • Full Member
  • ***
  • Posts: 114
Re: rx components failing to install on linux 64
« Reply #3 on: July 13, 2018, 03:10:05 pm »
it didn't work from sourceforge but I managed to get it installed using the online package manager

thanks

Dave

Thaddy

  • Hero Member
  • *****
  • Posts: 6754
Re: rx components failing to install on linux 64
« Reply #4 on: July 13, 2018, 03:44:24 pm »
But fcl-db belongs to fpc, and this has version 3.0.4 in both cases.
Note dbutils is from rx....
Ada's daddy wrote this:"Fools are my theme, let satire be my song."

lainz

  • Hero Member
  • *****
  • Posts: 2827
    • Home
Re: rx components failing to install on linux 64
« Reply #5 on: July 14, 2018, 05:36:21 am »
it fails on install as well on windows with laz trunk + fpc trunk as well.

wp

  • Hero Member
  • *****
  • Posts: 4916
Re: rx components failing to install on linux 64
« Reply #6 on: July 14, 2018, 10:04:40 am »
it fails on install as well on windows with laz trunk + fpc trunk as well.
Which rx version? The rx trunk from ccr compiles fine with Laz trunk, fpc 3.0.4, as well as the rx OPM version with Laz 1.8.4 / fpc 3.0.4 both on Windows. The version 1.1.5.98 which is used by the OP definitely does not compile, it is more than 10 years old.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

lainz

  • Hero Member
  • *****
  • Posts: 2827
    • Home
Re: rx components failing to install on linux 64
« Reply #7 on: July 14, 2018, 03:59:14 pm »
it fails on install as well on windows with laz trunk + fpc trunk as well.
Which rx version? The rx trunk from ccr compiles fine with Laz trunk, fpc 3.0.4, as well as the rx OPM version with Laz 1.8.4 / fpc 3.0.4 both on Windows. The version 1.1.5.98 which is used by the OP definitely does not compile, it is more than 10 years old.

the OPM version in Lazarus trunk and FPC trunk. Tried yesterday with a fresh FPCUPDeluxe installation.

wp

  • Hero Member
  • *****
  • Posts: 4916
Re: rx components failing to install on linux 64
« Reply #8 on: July 14, 2018, 05:51:19 pm »
OK, I must have had the combination of versions which works...

The problematic combination is RX-OPM version plus Laz trunk version: Laz trunk introduces high-dpi scaled bitmaps for buttons and removes the method TCustomEditButton.GetGlyph which is overridden in the RX-OPM version for its TCustomDateEdit. The issue is fixed in the trunk version of RX. Let's hope that Alexey soon updates the OPM version.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

lainz

  • Hero Member
  • *****
  • Posts: 2827
    • Home
Re: rx components failing to install on linux 64
« Reply #9 on: July 14, 2018, 06:18:24 pm »
Thankyou, yes I had to comment some lines in order to compile, but it was too late yesterday to see the lines I commented.

Good feature, I need to study that scaled bitmaps.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus