* * *

Author Topic: Lazarus IDE with Cocoa wont run using latest trunk  (Read 1505 times)

MISV

  • Sr. Member
  • ****
  • Posts: 415
Re: Lazarus IDE with Cocoa wont run using latest trunk
« Reply #15 on: July 12, 2018, 01:35:33 pm »
At least my bug report now includes stack trace for both errors...
https://bugs.freepascal.org/view.php?id=33969#bugnotes

I think maybe the issues related since one bug often causes another, so they have been reported together.

Phil

  • Hero Member
  • *****
  • Posts: 2749
Re: Lazarus IDE with Cocoa wont run using latest trunk
« Reply #16 on: July 12, 2018, 02:05:51 pm »
Thanks Phil,

Is it possible to make the command:

open lazarus.app --args "--pcp=~/.laz_trunk"

an alias?

Just put it in a script file.

Phil

  • Hero Member
  • *****
  • Posts: 2749
Re: Lazarus IDE with Cocoa wont run using latest trunk
« Reply #17 on: July 12, 2018, 02:08:50 pm »
Are you also using the newest macOS version?

I compiled and tested trunk Laz on El Capitan, 10.11.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4781
    • wiki
Re: Lazarus IDE with Cocoa wont run using latest trunk
« Reply #18 on: July 12, 2018, 02:36:31 pm »
Thanks Phil,

Is it possible to make the command:

open lazarus.app --args "--pcp=~/.laz_trunk"

an alias?

Just put it in a script file.

It might be possible to but the --pcp into a lazarus.cfg file in the lazarus directory.

I havent tested it on Mac though.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus