* * *

Author Topic: Fatal: illegal character "'($C2)  (Read 827 times)

VTwin

  • Sr. Member
  • ****
  • Posts: 424
  • Former Turbo Pascal 3 user
Re: Fatal: illegal character "'($C2)
« Reply #15 on: July 02, 2018, 03:49:58 pm »
On my PowerBook, Mac OS 10.11.5,  running Ubuntu 16.04 LT on VirtualBox,  I can not reproduce the error.

Maybe a keyboard malfunction?
“Talk is cheap. Show me the code.” Linus Torvalds

Lazarus 1.8.4, FPC 3.0.4
macOS 10.11.5 (32 bit Carbon, working on Cocoa) 
Windows 7 (64 bit)
Ubuntu 16.04.3 (64 bit)

Handoko

  • Hero Member
  • *****
  • Posts: 2378
  • My goal: build my own game engine using Lazarus
Re: Fatal: illegal character "'($C2)
« Reply #16 on: July 02, 2018, 04:08:00 pm »
Maybe a keyboard malfunction?

The OP said the problem only happens when running Lazarus on his Mac, not other software. So it should not be hardware problem.

@ThierryJ
Can you find another Mac machine (maybe borrow from your friend) and test on it?

Thaddy

  • Hero Member
  • *****
  • Posts: 6330
Re: Fatal: illegal character "'($C2)
« Reply #17 on: July 02, 2018, 04:38:58 pm »
@Thierry
I can not reproduce it on my Mac mini. That is unless I set an A circonflex in the sourcecode on purpose.
The compiler gives me the EXACT line and the EXACT position where I put it (as I wrote before).
Send us a screenshot of what the compiler output is.
I am enjoining wine, not whine....

engkin

  • Hero Member
  • *****
  • Posts: 2017
Re: Fatal: illegal character "'($C2)
« Reply #18 on: July 02, 2018, 05:56:46 pm »
@Thaddy, try Option+Space

ThierryJ

  • New member
  • *
  • Posts: 16
Re: Fatal: illegal character "'($C2)
« Reply #19 on: July 02, 2018, 06:56:40 pm »
@mercurhyo : I have already described it. The behavior is the same.
@Thaddy : I have joined a pdf with screen copies of the problem with a previous message.
@Handoko : You are right. I just checked with another, older Apple keyboard, the problem is the same.

In the mean time I have done another test : I have created a fresh Writer document with LibreOffice and put inside the magical phrase, For i := 0 To High(toto) Do something.
Than I have opened the document package, unpacked the file content.xml and fed it to ghex. Everything is perfect, the spaces are 32...

Than I have restarted a new Lazarus project, a new Unit with a single Class. The problem occurred only once right after the "=" in TMyClass = Class...
Than I have created another Class, and all the spaces following = have been replaced.
The attached file shows this.

Finally I have tried to write the same "Class" in a Windows 10 Virtual Machine, and it works...

To be short, the conflict may be with Lazarus running on Debian with a Swiss French keyboard. But I cannot investigate further, I don't have the skills to do it by myself.

Any idea welcome, thanks all for your time.





 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus