Recent

Author Topic: Lazarus Release 1.8.4 (with FPC 3.0.4)  (Read 71607 times)


mischi

  • Full Member
  • ***
  • Posts: 113
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #61 on: October 05, 2018, 11:17:42 pm »
No. But if you really need 64bit, you can build it with the cocoa or qt4 lcl. Or wait until there is the release and i have created the package description for fink. As soon as fink is ready for Mojave, 64-bit lazarus-1.8.4 will be available.

MiSchi

alex523

  • Newbie
  • Posts: 2
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #62 on: October 06, 2018, 12:04:52 am »
No. But if you really need 64bit, you can build it with the cocoa or qt4 lcl. Or wait until there is the release and i have created the package description for fink. As soon as fink is ready for Mojave, 64-bit lazarus-1.8.4 will be available.

MiSchi

I am looking for native gui control support.

mischi

  • Full Member
  • ***
  • Posts: 113
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #63 on: October 06, 2018, 08:48:26 am »
I am looking for native gui control support.
Do you mean using lazarus with the cocoa-lcl or using Apple's interface builder and fit your pascal code into that?

USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #64 on: October 31, 2018, 07:29:39 pm »
How to install Lazarus ,FPC 3.0.4 in the Knoppix  7.2, 7.7.1,8.1, 8.2  as .deb package in the offline mode for i386, x64 mode for PC with UEFI supporting and without it ? How to install additional modules for new  DVD      Knoppix  7.2, 7.7.1,8.1, 8.2 (into RAM)?
FPC works, but problems  with dep modules of the Lazarus (Gnome) are not fixed .

USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #65 on: October 31, 2018, 07:32:46 pm »
How to install Lazarus on Knoppix 7.2 and 8.1  in the RAM of the VirtualBox , LiveMode   , using solid .deb package for them ?

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3548
  • I like bugs.
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #66 on: October 31, 2018, 08:45:56 pm »
USERPC01, why do you want to use .deb packages? If FPC works, get Lazarus sources from SVN and build it.

USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #67 on: November 18, 2018, 11:59:05 am »

I could not install appropriate version of libgtk2.0-dev for this package.
Which package with deps is compatible with this OS.
In the Knoppix 7.2 (Virtualbox, x32 mode  ) works this

Code: [Select]
sudo dpkg -i fpc_2.6.4-140420_i386.deb
sudo dpkg -i fpc-src_2.6.4-140420_i386.deb

sudo dpkg -i libgtk2.0-dev_2.24.10-2_i386.deb

sudo dpkg -i lazarus_1.2.2-0_i386.deb
But I could not install libgtk2.0-dev for lazarus 1.2.2, >1.4.4 and deps for this package in the Knoppix 8.1 .8.2  .


USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #68 on: November 18, 2018, 02:28:19 pm »
If I use lazarus 1.6.4 on the knoppix 8.1 in the  VirtualBox , it wirks with

Code: [Select]

sudo dpkg -i  gir1.2-gtk-2.0_2.24.31-2_i386.deb
sudo dpkg -i  libgtk2.0-common_2.24.31-2_all.deb
sudo dpkg -i  libgtk2.0-dev_2.24.31-2_i386.deb

sudo dpkg -i  fpc_3.0.2-170225_i386.deb
sudo dpkg -i  fpc-src_3.0.2-170225_i386.deb
sudo dpkg -i  lazarus-project_1.6.4-0_i386.deb


, but some errors with types were found during the installation.
If I use  Lazarus  >1.8.4
Code: [Select]
sudo dpkg -i  gir1.2-gtk-2.0_2.24.31-2_i386.deb
sudo dpkg -i  libgtk2.0-common_2.24.31-2_all.deb
sudo dpkg -i  libgtk2.0-dev_2.24.31-2_i386.deb

sudo dpkg -i fpc_3.0.4-3_i386.deb
sudo dpkg -i  fpc-src_3.0.4-1_i386.deb
sudo dpkg -i lazarus-project_1.8.4-0_i386.deb
, I could not compile test applicatrion  with GUI.
 

USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #69 on: November 18, 2018, 02:32:24 pm »
In the  Knoppix 8.2 found problem with downgrading  libgtk2.0-dev_2.24.32 to  libgtk2.0-dev_2.24.31-2_i386.deb   .

USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #70 on: November 18, 2018, 03:59:49 pm »
For Knoppix 8.1 (i386):

Code: [Select]

knoppix@Microknoppix:~/Desktop/lazarus1_6_4$ sudo dpkg -i  gir1.2-gtk-2.0_2.24.31-2_i386.deb
Selecting previously unselected package gir1.2-gtk-2.0.
dpkg: warning: files list file for package 'cloop-utils' missing; assuming package has no files currently installed
(Reading database ... 449909 files and directories currently installed.)
Preparing to unpack gir1.2-gtk-2.0_2.24.31-2_i386.deb ...
Unpacking gir1.2-gtk-2.0 (2.24.31-2) ...
Setting up gir1.2-gtk-2.0 (2.24.31-2) ...
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$ sudo dpkg -i  libgtk2.0-common_2.24.31-2_all.deb
dpkg: warning: files list file for package 'cloop-utils' missing; assuming package has no files currently installed
(Reading database ... 449916 files and directories currently installed.)
Preparing to unpack libgtk2.0-common_2.24.31-2_all.deb ...
Unpacking libgtk2.0-common (2.24.31-2) over (2.24.31-2) ...
Setting up libgtk2.0-common (2.24.31-2) ...
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$ sudo dpkg -i  libgtk2.0-dev_2.24.31-2_i386.deb
Selecting previously unselected package libgtk2.0-dev.
dpkg: warning: files list file for package 'cloop-utils' missing; assuming package has no files currently installed
(Reading database ... 449916 files and directories currently installed.)
Preparing to unpack libgtk2.0-dev_2.24.31-2_i386.deb ...
Unpacking libgtk2.0-dev (2.24.31-2) ...
Setting up libgtk2.0-dev (2.24.31-2) ...
Processing triggers for man-db (2.7.6.1-2) ...
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$ sudo dpkg -i  fpc_3.0.2-170225_i386.deb
Selecting previously unselected package fpc.
dpkg: warning: files list file for package 'cloop-utils' missing; assuming package has no files currently installed
(Reading database ... 450201 files and directories currently installed.)
Preparing to unpack fpc_3.0.2-170225_i386.deb ...
Unpacking fpc (3.0.2) ...
Setting up fpc (3.0.2) ...
Running on linux
Write permission in /etc.
Writing sample configuration file to /etc/fpc.cfg
Writing sample configuration file to /usr/lib/fpc/3.0.2/ide/text/fp.cfg
Writing sample configuration file to /usr/lib/fpc/3.0.2/ide/text/fp.ini
Writing sample configuration file to /etc/fppkg.cfg
Writing sample configuration file to /etc/fppkg/default
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$ sudo dpkg -i  fpc-src_3.0.2-170225_i386.deb
Selecting previously unselected package fpc-src.
dpkg: warning: files list file for package 'cloop-utils' missing; assuming package has no files currently installed
(Reading database ... 453257 files and directories currently installed.)
Preparing to unpack fpc-src_3.0.2-170225_i386.deb ...
Unpacking fpc-src (3.0.2) ...

Setting up fpc-src (3.0.2) ...
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$
knoppix@Microknoppix:~/Desktop/lazarus1_6_4$ sudo dpkg -i  lazarus-project_1.6.4-0_i386.deb
Selecting previously unselected package lazarus-project.
dpkg: warning: files list file for package 'cloop-utils' missing; assuming package has no files currently installed
(Reading database ... 470435 files and directories currently installed.)
Preparing to unpack lazarus-project_1.6.4-0_i386.deb ...
Unpacking lazarus-project (1.6.4) ...
Setting up lazarus-project (1.6.4) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for desktop-file-utils (0.23-2) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for shared-mime-info (1.8-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'



How to fix
Code: [Select]
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'



USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #71 on: November 18, 2018, 04:01:55 pm »
How to fix "dpkg: warning: files list file for package 'cloop-utils'  "?  What package is necessary for fix it ?

USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #72 on: November 18, 2018, 06:39:08 pm »
I use for Knoppix 8.1  :
Code: [Select]

sudo dpkg -i  gir1.2-gtk-2.0_2.24.31-2_i386.deb
sudo dpkg -i  libgtk2.0-common_2.24.31-2_all.deb
sudo dpkg -i  libgtk2.0-dev_2.24.31-2_i386.deb

sudo dpkg -i fpc_3.0.4-3_i386.deb
sudo dpkg -i  fpc-src_3.0.4-1_i386.deb
sudo dpkg -i lazarus-project_1.8.4-0_i386.deb
How to fix  problem with /usr/bin/ppc386     ?


USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #73 on: November 18, 2018, 06:41:28 pm »
How to run Lazarus 1.8.4  in the  Knoppix 8.1  / 8.2   (problem with symbolic link for the /usr/bin/ppc386)    ?     

USERPC01

  • New member
  • *
  • Posts: 11
Re: Lazarus Release 1.8.4 (with FPC 3.0.4)
« Reply #74 on: November 22, 2018, 06:34:07 pm »
I was execute next(boot from CD without  Virtualbox,from RAM):


Code: [Select]
sudo dpkg -i  gir1.2-gtk-2.0_2.24.31-2_i386.deb
sudo dpkg -i  libgtk2.0-common_2.24.31-2_all.deb
sudo dpkg -i  libgtk2.0-dev_2.24.31-2_i386.deb

sudo dpkg -i fpc_3.0.4-3_i386.deb
sudo dpkg -i  fpc-src_3.0.4-1_i386.deb
sudo dpkg -i lazarus-project_1.8.4-0_i386.deb


Code: [Select]
knoppix@Microknoppix:~/Desktop/lazarus$ sudo dpkg -i lazarus-project_1.8.4-0_i386.deb
dpkg: warning: files list file for package 'cloop-utils' missing; assuming package has no files currently installed
(Reading database ... 470444 files and directories currently installed.)
Preparing to unpack lazarus-project_1.8.4-0_i386.deb ...
Unpacking lazarus-project (1.8.4) ...
Setting up lazarus-project (1.8.4) ...
Processing triggers for shared-mime-info (1.8-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Processing triggers for desktop-file-utils (0.23-2) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for mime-support (3.60) ...
knoppix@Microknoppix:~/Desktop/lazarus$


« Last Edit: November 22, 2018, 06:38:32 pm by USERPC01 »