Using the Lazarus IDE > Designer

4k video laptop won't produce forms in app the same size as developed in the IDE

(1/1)

cletsche43:
I just bought an HP SPECTRE 360 with a 4k video card.  My screen resolution is 3840 by 2160, so when I design forms at the size I want them, with the size fonts I want, the come out about 4 to 8 times larger when the app is compiled and run.  I have tried changing my screen resolutions to lower settings, but nothing works.  Is there a fix for this problem, or will I not be able to use Lazarus on my new computer?  Please help.  This has to be a common problem.

Thanks,
Cary

Pascal:
Try checking "use LCL scaling (Hi-DPI)" in project options.

Thaddy:
You need at least Laz 1.8.2 for that to work and there are improvements in trunk.

cletsche43:
I have that version of Lazarus.  What do you mean by "the trunk"?
Cary

cletsche43:
Thanks PASCAL,

That sort of worked.  I had to change the Font size on everything in all my forms to make it look correct.  But that did not work for the Main Form of my program.  The fonts did not change at all.  I had to choose a font size of 30 to make it look like 10.

Navigation

[0] Message Index

Go to full version