* * *

Author Topic: Error Installing LNet lazarus v1.8.2 (ubuntu 18.04)  (Read 1682 times)

pmrelvas

  • Newbie
  • Posts: 3
Error Installing LNet lazarus v1.8.2 (ubuntu 18.04)
« on: May 03, 2018, 10:31:52 pm »
Hello everyone,

First of all, I'm sorry if I'm doing anything wrong, this is my first topic here.
I'm having an issue while trying to install the latest version of lazarus ide (v1.8.2) on ubuntu 18.04. I checkout the latest version from the svn repository (I guess it is 0.6.6), but when I try to compile the lnetvisual package I get he following error: lnetssl.pp(512,29) Error: Identifier not found "SslTLSMethod"
I'm sending an attached image on the file where I'm getting the error.
Can anybody help me with this please?
thanks in advance

Cheers

teodor4ik

  • Newbie
  • Posts: 3
Re: Error Installing LNet lazarus v1.8.2 (ubuntu 18.04)
« Reply #1 on: May 05, 2018, 02:06:03 pm »
+1 Got same under Win7x64 in 1.6.2 IDE

lainz

  • Hero Member
  • *****
  • Posts: 2878
    • Home
Re: Error Installing LNet lazarus v1.8.2 (ubuntu 18.04)
« Reply #2 on: May 05, 2018, 04:36:17 pm »
Use fphttpclient or Indy, both works fine.

pmrelvas

  • Newbie
  • Posts: 3
Re: Error Installing LNet lazarus v1.8.2 (ubuntu 18.04)
« Reply #3 on: May 05, 2018, 06:31:47 pm »
Hello,

Thank you for your reply. Unfortunately I need lnet in order to open an already existing project I'm working on. Can anybody help me to run lnet in this version please?
Thanks in advance :)

Kind regards

wp

  • Hero Member
  • *****
  • Posts: 5042
Re: Error Installing LNet lazarus v1.8.2 (ubuntu 18.04)
« Reply #4 on: May 05, 2018, 06:55:25 pm »
I installed the version of LNet which is distributed by Online-Package-Manager (OPM) in Win10 64-bit (Laz 1.8.2 / 32 bit) and in Linux Mint 18.1 (32 bit) (Laz trunk / fpc 3.04) - and none of the installations made any problems.

And yes, I can confirm that the svn version does not compile with fpc 3.0.4 and below. If I switch to fpc-trunk, however, no problems here, too.

If you don't know OPM - it is coming with Lazarus since version 1.8, but it is not installed by default. Open "Packages" > "Install/Uninstall packages", find "OnlinePackageManager" in the right list of "available packages", click "Install selection" and "Save and rebuild IDE". After the installation has completed and Lazarus has restarted you'll find OPM in the menu "Packages" as last item.

« Last Edit: May 05, 2018, 07:00:34 pm by wp »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

pmrelvas

  • Newbie
  • Posts: 3
Re: Error Installing LNet lazarus v1.8.2 (ubuntu 18.04)
« Reply #5 on: May 07, 2018, 08:54:54 pm »
Thank you so much for your answer @wp ! it worked!
I was able to install lnet through online package manager, using fpc 3.0.4 and lazarus 1.8.2 (release version).

Kind regards

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus