* * *

Author Topic: [SOLVED]Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux  (Read 1107 times)

qlixes

  • New member
  • *
  • Posts: 7
[SOLVED]Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« on: May 03, 2018, 12:58:30 pm »
Dear Sir,

I have question to ask about installing lazarus trunk 1.9 (rev 57775) , fpc trunk 3.1.1 and fpc-src trunk 3.1.1 (rev 38896) on Archlinux based (I'm using AntergosOS).
I'm installing from AUR packages and succeed, but on doesn't has AUR packages for lazarus-gtk2 svn, so I could run lazarus IDE.
I've tried for using lazarus stable on lazarus-gtk2 1.8.2 and tried to running with (force) installed trunk version of lazarus, fpc,fpc-src (yes, it shown that warning about wrong version on ide/version.inc : 1.9)
while trying to build IDE (lazarus-gtk2 1.8.2) with clean common files + clean all, I've found problem.
Code: Pascal  [Select]
  1. Compile package FCL 1.0.1: Exit code 256, Errors: 1, Warnings: 1
  2. Warning: Recompiling Variants, checksum changed for /usr/lib/fpc/3.1.1/units/x86_64-linux/rtl/math.ppu {impl}
  3. variants.pp(11,71) Fatal: Can't find unit Variants used by DB
  4.  
while checking on DB (path=/usr/lib/fpc/src/packages/fcl-db/src/base/db.pas), it used Variants unit (path=/usr/lib/fpc/src/packages/rtl-objpas/src/inc/variants.pp).
May I know if I've has some missing information about using lazarus trunk version.
Thanks a lot

my sistem : Linux Kaneki 4.16.6-1-ARCH #1 SMP PREEMPT Mon Apr 30 12:30:03 UTC 2018 x86_64 GNU/Linux

note : first time using stable version fpc 3.0.4,  fpc-src 3.0.4 and lazarus 1.8.2 on official repo. then tried to download trunk version

Thanks a lot


SOLVE : install FPCUPDELUXE for build any version of FPC and Lazarus (stable/trunk/ etc)
« Last Edit: May 04, 2018, 01:03:27 am by qlixes »

qlixes

  • New member
  • *
  • Posts: 7
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #1 on: May 03, 2018, 01:12:53 pm »
Add Info :
these add error information
Code: Pascal  [Select]
  1. /usr/bin/ppcx64 -MObjFPC -Scghi -O1 -g -gl -l -vewnhibq -Fu. -Fu/usr/lib/fpc/3.1.1/units/x86_64-linux/rtl -FE. -FU../units/x86_64-linux -Cg -dx86_64 fcllaz.pas
  2. Hint: (11030) Start of reading config file /etc/fpc.cfg
  3. Hint: (11031) End of reading config file /etc/fpc.cfg
  4. Free Pascal Compiler version 3.1.1 [2018/05/03] for x86_64
  5. Copyright (c) 1993-2018 by Florian Klaempfl and others
  6. (1002) Target OS: Linux for x86-64
  7. (3104) Compiling fcllaz.pas
  8. (10001) PPU Loading /usr/lib/fpc/3.1.1/units/x86_64-linux/rtl-objpas/variants.ppu
  9. (10011) PPU Source: variants.pp not available
  10. (10028) Recompiling Variants, checksum changed for /usr/lib/fpc/3.1.1/units/x86_64-linux/rtl/math.ppu {impl}
  11. /usr/lib/fpc/3.1.1/units/x86_64-linux/rtl-objpas/variants.ppu:variants.pp(11,71) Fatal: (10022) Can't find unit Variants used by DB
  12. Fatal: (1018) Compilation aborted
  13. make[1]: *** [Makefile:2785: fcllaz.ppu] Error 1
  14. make[1]: Leaving directory '/opt/lazarus/lazarus-gtk2-svn/src/lazarus-gtk2-svn/packager/registration'
  15. make: *** [Makefile:3237: registration] Error 2
  16.  
May I've missed something ?
Thanks a lot
« Last Edit: May 03, 2018, 01:16:43 pm by qlixes »

Thaddy

  • Hero Member
  • *****
  • Posts: 6370
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #2 on: May 03, 2018, 01:37:14 pm »
I can't reproduce this on my webserver server that runs arch-linux-x86_64.
delete /etc/fpc.cfg first.
Try for FPC just: make clean all instal PP=/the/path/to/your/bootstrap/compiler/ppcx64
Then for Lazarus just: make clean all or make clean bigide.
Note make sure the bootstrap compiler for FPC ppcx64 is version 3.0.4. Anything else is not supported.
« Last Edit: May 03, 2018, 01:41:37 pm by Thaddy »
I am enjoining wine, not whine....

qlixes

  • New member
  • *
  • Posts: 7
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #3 on: May 03, 2018, 02:09:53 pm »
Dear Sir @Thaddy
Thank you for replying.
May I know what kind method you've used with gpc 3.1.1 and lazarus 1.9 ? manually or use aur packages ?
if you used aur packages, may i know where i could find it ?
thanks a lot

note: while tried to compile with fpc 3.0.4, fpc-src 3.1.1(svn) lazarus 1.9 (svn) for creating aur packages for lazarus-gtk2 is okay and build IDE was okay. but while using fpc 3.1.1, found same issue.
thanks a lot

BeanzMaster

  • Full Member
  • ***
  • Posts: 146
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #4 on: May 03, 2018, 02:32:33 pm »
Hi Have you try to install them from FPCUpDeluxe ?

See : http://forum.lazarus.freepascal.org/index.php/topic,34645.msg284858.html#msg284858

Thaddy

  • Hero Member
  • *****
  • Posts: 6370
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #5 on: May 03, 2018, 02:52:25 pm »
Dear Sir @Thaddy
Thank you for replying.
May I know what kind method you've used with gpc 3.1.1 and lazarus 1.9 ? manually or use aur packages ?
if you used aur packages, may i know where i could find it ?
thanks a lot

note: while tried to compile with fpc 3.0.4, fpc-src 3.1.1(svn) lazarus 1.9 (svn) for creating aur packages for lazarus-gtk2 is okay and build IDE was okay. but while using fpc 3.1.1, found same issue.
thanks a lot
I always compile from source,  manually. But to obtain the bootstrap compiler I sometimes use fpcdeluxe or an official deb (arch linux accepts deb see e.g.: https://unix.stackexchange.com/questions/83540/installing-a-deb-package-on-arch-is-it-possible )
I am enjoining wine, not whine....

qlixes

  • New member
  • *
  • Posts: 7
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #6 on: May 03, 2018, 04:11:08 pm »
Dear @BeanzMaster
I'll try installing for fpcdeluxe. but my question did it support fpc+lazarus trunk version ?
Dear @Thaddy
I have tried install all source svn with fpc 3.0.4 from aur packages (fpc-src-svn, fpc-svn, lazarus-svn, lazarus-gtk2-svn) and didn't show any error, it worked.
but while want to install onlinepackagemanager then build, it shown failed on same issue.
Maybe have some info about stable version trunk were working fine
Thanks a lot

Cyrax

  • Hero Member
  • *****
  • Posts: 579
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #7 on: May 03, 2018, 04:16:41 pm »
You need to generate fpc.cfg configuration file with just built fpcmkcfg utility form the trunk.

fpcmkcfg -o <where the fpc binary lies>/fpc.cfg -d basepath=<to where the unit directory is> -d sharepath=<to where the unicode map data is>

BeanzMaster

  • Full Member
  • ***
  • Posts: 146
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #8 on: May 03, 2018, 11:12:53 pm »
Dear @BeanzMaster
I'll try installing for fpcdeluxe. but my question did it support fpc+lazarus trunk version ?

Yes FPCUpDeluxe support fpc trunk and from version 2.0 to 3.1.1 + lazarus trunk and from version 0.9.4 to 1.9 . Reads my tutorial  (see my link above) it can help you (it's in french but you can translate it from microsoft translator online-tool on top left of the page)

qlixes

  • New member
  • *
  • Posts: 7
Re: Lazarus Trunk 1.9 + FPC Trunk 3.1.1 on Archlinux
« Reply #9 on: May 04, 2018, 01:02:03 am »
Dear All,
I've followed fpcupdeluxe for installing fpc+lazarus trunk version and succeed without any problem.
I have some question,
1. what's different on  fpcbuild and fpc ? SOLVE : check on https://www.freepascal.org/develop.var
2. on arch or ubuntu, I've found for working lazarus must install fpc, fpc-src and lazarus.
my question what kind of trunk version for getting fpc and fpc-src, did it using fpcbuild trunk version
3. on fpcupdeluxe using fpc standalone trunk version and lazarus standalone trunk version was succeed. my question : fpcbuild has fpdocs and fpcsrc, from aur snapshot will create fpc-src-svn and fpc-svn and must install before lazarus-svn, but they were same issue as could not find any Variants unit, but while try jump into unit db and jump link Variants, that unit was found but couldnot detected on lazarus while build, compile etc
Please let me learn it more deep about archlinux aur for lazarus svn version.
Anyway thanks a lot for letting me know about fpcupdeluxe

SOLVE : install FPC and Lazarus trunk version or other with FPCUPDELUXE
« Last Edit: May 04, 2018, 01:20:23 am by qlixes »

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus