* * *

Author Topic: Can't Install Packages on a Fresh Install of Lazarus  (Read 237 times)

Landslyde

  • Jr. Member
  • **
  • Posts: 91
Can't Install Packages on a Fresh Install of Lazarus
« on: April 08, 2018, 12:14:02 am »
I tried to add a couple packages through the IDE and keep getting an error when I try to rebuild and restart Lazarus. This is the error:
Code: Pascal  [Select]
  1. Build IDE: Exit code 512, Errors: 1
  2. lazarus.pp(1,1) Fatal: Cannot find lazcontroldsgn used by Lazarus.

lazcontroldsgn is already installed (by default). A click on it from the Install/Uninstall window shows this:
Code: Pascal  [Select]
  1. Filename:  /usr/lib/lazarus/1.8.2/components/lazcontrols/design/lazcontroldsgn.lpk
  2. Current state: installed, DesignTime

I've uninstalled lazcontroldsgn and reinstalled it, but that didn't change anything. Same error when I try to install other packages. Does anyone know a way around this? There are a few packages that I really want to install here.
Linux Mint 18.3 64-bit
Lazarus 1.8.2
FPC 3.0.4

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus