* * *

Author Topic: [SOLVED] Need Help Installing FPC  (Read 780 times)

Landslyde

  • Full Member
  • ***
  • Posts: 163
[SOLVED] Need Help Installing FPC
« on: April 07, 2018, 01:54:50 pm »
Hello Forum:

I have a helluva mess here and need help straightening it out so I can use fpc 3.0.4-2 and Lazarus 1.8.2-0. It seems I had an older version of fpc already installed and the fpc deb files wouldn't take. This is what I get from the package installer:
Code: Pascal  [Select]
  1. dpkg: regarding .../fpc_3.0.4-2_amd64.deb containing fpc:
  2.  fpc conflicts with fpc
  3.   fpc-3.0.0 provides fpc and is present and installed.
  4.  
  5. dpkg: error processing archive /home/floyd/Downloads/fpc_3.0.4-2_amd64.deb (--install):
  6.  conflicting packages - not installing fpc
  7. Selecting previously unselected package fpc.
  8. dpkg: regarding .../fpc_3.0.4-2_amd64.deb containing fpc:
  9.  fpc conflicts with fp-compiler
  10.   fp-compiler (version 3.0.0+dfsg-2) is present and installed.
  11.   fp-compiler-3.0.0 provides fp-compiler and is present and installed.
  12.  
  13. dpkg: error processing archive /home/floyd/Downloads/fpc_3.0.4-2_amd64.deb (--install):
  14.  conflicting packages - not installing fpc
  15. dpkg: regarding .../fpc_3.0.4-2_amd64.deb containing fpc:
  16.  fpc conflicts with fp-compiler
  17.   fp-compiler (version 3.0.0+dfsg-2) is present and installed.
  18.   fp-compiler-3.0.0 provides fp-compiler and is present and installed.
  19.  
  20. dpkg: error processing archive /home/floyd/Downloads/fpc_3.0.4-2_amd64.deb (--install):
  21.  conflicting packages - not installing fpc

So I did this:
Code: Pascal  [Select]
  1. floyd@floyd-HP-Pavilion-Desktop-PC-570-p0xx ~ $ sudo apt-get remove --purge fpc*
  2. [sudo] password for floyd:
  3. Reading package lists... Done
  4. Building dependency tree      
  5. Reading state information... Done
  6. Note, selecting 'fpc-3.0.0' for glob 'fpc*'
  7. Note, selecting 'fpc' for glob 'fpc*'
  8. Note, selecting 'fpc-src' for glob 'fpc*'
  9. Note, selecting 'fpc-abi-3.0.0' for glob 'fpc*'
  10. Note, selecting 'fpc-source' for glob 'fpc*'
  11. Note, selecting 'fpc-source-3.0.0' for glob 'fpc*'
  12. Note, selecting 'fp-units-rtl-3.0.0' instead of 'fpc-abi-3.0.0'
  13. Package 'fpc-src' is not installed, so not removed
  14. Package 'fpc-source' is not installed, so not removed
  15. The following packages were automatically installed and are no longer required:
  16.   fp-ide-3.0.0 fp-units-base-3.0.0 fp-units-db-3.0.0 fp-units-fcl-3.0.0 fp-units-fv-3.0.0 fp-units-gfx-3.0.0 fp-units-gtk2-3.0.0 fp-units-math-3.0.0 fp-units-misc-3.0.0 fp-units-multimedia-3.0.0 fp-units-net-3.0.0 gir1.2-gtk-2.0 libatk1.0-dev
  17.   libcairo-script-interpreter2 libcairo2-dev libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libice-dev libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5
  18.   libpixman-1-dev libpng12-dev libsm-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev x11proto-composite-dev x11proto-randr-dev x11proto-render-dev x11proto-xinerama-dev
  19. Use 'sudo apt autoremove' to remove them.
  20. The following packages will be REMOVED:
  21.   fpc* fpc-3.0.0* fpc-source-3.0.0*
  22. 0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
  23. After this operation, 167 MB disk space will be freed.
  24. Do you want to continue? [Y/n]
  25. (Reading database ... 358524 files and directories currently installed.)
  26. Removing fpc (3.0.0+dfsg-2) ...
  27. Removing fpc-3.0.0 (3.0.0+dfsg-2) ...
  28. Removing fpc-source-3.0.0 (3.0.0+dfsg-2) ...
  29.  

Then I ran autoremove:
Code: Pascal  [Select]
  1. floyd@floyd-HP-Pavilion-Desktop-PC-570-p0xx ~ $ sudo apt autoremove
  2. Reading package lists... Done
  3. Building dependency tree      
  4. Reading state information... Done
  5. The following packages will be REMOVED:
  6.   fp-ide-3.0.0 fp-units-base-3.0.0 fp-units-db-3.0.0 fp-units-fcl-3.0.0 fp-units-fv-3.0.0 fp-units-gfx-3.0.0 fp-units-gtk2-3.0.0 fp-units-math-3.0.0 fp-units-misc-3.0.0 fp-units-multimedia-3.0.0 fp-units-net-3.0.0 gir1.2-gtk-2.0 libatk1.0-dev
  7.   libcairo-script-interpreter2 libcairo2-dev libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libice-dev libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5
  8.   libpixman-1-dev libpng12-dev libsm-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev x11proto-composite-dev x11proto-randr-dev x11proto-render-dev x11proto-xinerama-dev
  9. 0 upgraded, 0 newly installed, 42 to remove and 0 not upgraded.
  10. After this operation, 139 MB disk space will be freed.
  11. Do you want to continue? [Y/n]
  12. (Reading database ... 350263 files and directories currently installed.)
  13. Removing fp-ide-3.0.0 (3.0.0+dfsg-2) ...
  14. Removing fp-units-gfx-3.0.0 (3.0.0+dfsg-2) ...
  15. Removing fp-units-gtk2-3.0.0 (3.0.0+dfsg-2) ...
  16. Removing fp-units-fcl-3.0.0 (3.0.0+dfsg-2) ...
  17. Removing fp-units-base-3.0.0 (3.0.0+dfsg-2) ...
  18. Removing fp-units-db-3.0.0 (3.0.0+dfsg-2) ...
  19. Removing fp-units-fv-3.0.0 (3.0.0+dfsg-2) ...
  20. Removing fp-units-math-3.0.0 (3.0.0+dfsg-2) ...
  21. Removing fp-units-misc-3.0.0 (3.0.0+dfsg-2) ...
  22. Removing fp-units-multimedia-3.0.0 (3.0.0+dfsg-2) ...
  23. Removing fp-units-net-3.0.0 (3.0.0+dfsg-2) ...
  24. Removing libgtk2.0-dev (2.24.30-1ubuntu1.16.04.2) ...
  25. Removing gir1.2-gtk-2.0 (2.24.30-1ubuntu1.16.04.2) ...
  26. Removing libatk1.0-dev (2.18.0-1) ...
  27. Removing libpango1.0-dev (1.38.1-1) ...
  28. Removing libcairo2-dev (1.14.6-1) ...
  29. Removing libcairo-script-interpreter2:amd64 (1.14.6-1) ...
  30. Removing libxft-dev (2.3.2-1) ...
  31. Removing libfontconfig1-dev:amd64 (2.11.94-0ubuntu1.1) ...
  32. Removing libfreetype6-dev:amd64 (2.6.1-0.1ubuntu2.3) ...
  33. Removing libgdk-pixbuf2.0-dev (2.32.2-1ubuntu1.4) ...
  34. Removing libglib2.0-dev (2.48.2-0ubuntu1) ...
  35. Removing libharfbuzz-dev (1.0.1-1ubuntu0.1) ...
  36. Removing libharfbuzz-gobject0:amd64 (1.0.1-1ubuntu0.1) ...
  37. Removing libsm-dev:amd64 (2:1.2.2-1) ...
  38. Removing libice-dev:amd64 (2:1.0.9-1) ...
  39. Removing libpcre3-dev:amd64 (2:8.38-3.1) ...
  40. Removing libpcre32-3:amd64 (2:8.38-3.1) ...
  41. Removing libpcrecpp0v5:amd64 (2:8.38-3.1) ...
  42. Removing libpixman-1-dev (0.33.6-1) ...
  43. Removing libpng12-dev:amd64 (1.2.54-1ubuntu1) ...
  44. Removing libxcb-shm0-dev:amd64 (1.11.1-1ubuntu1) ...
  45. Removing libxcomposite-dev (1:0.4.4-1) ...
  46. Removing libxcursor-dev:amd64 (1:1.1.14-1ubuntu0.16.04.1) ...
  47. Removing libxi-dev (2:1.7.6-1) ...
  48. Removing libxinerama-dev:amd64 (2:1.1.3-1) ...
  49. Removing libxrandr-dev:amd64 (2:1.5.0-1) ...
  50. Removing libxrender-dev:amd64 (1:0.9.9-0ubuntu1) ...
  51. Removing x11proto-composite-dev (1:0.4.2-2) ...
  52. Removing x11proto-randr-dev (1.5.0-1) ...
  53. Removing x11proto-render-dev (2:0.11.1-2) ...
  54. Removing x11proto-xinerama-dev (1.2.1-2) ...
  55. Processing triggers for man-db (2.7.5-1) ...
  56. Processing triggers for libc-bin (2.23-0ubuntu10) ...
  57. Processing triggers for doc-base (0.10.7) ...
  58. Processing 2 removed doc-base files...
  59. Registering documents with scrollkeeper...
  60. Processing triggers for libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
  61. floyd@floyd-HP-Pavilion-Desktop-PC-570-p0xx ~ $

And when I tried to reinstall the new fpc again, I got the same msg:
Code: Pascal  [Select]
  1. dpkg: regarding .../fpc_3.0.4-2_amd64.deb containing fpc:
  2.  fpc conflicts with fpc
  3.   fpc-3.0.0 provides fpc and is present and installed.
  4.  
  5. dpkg: error processing archive /home/floyd/Downloads/fpc_3.0.4-2_amd64.deb (--install):
  6.  conflicting packages - not installing fpc
  7. Selecting previously unselected package fpc.
  8. dpkg: regarding .../fpc_3.0.4-2_amd64.deb containing fpc:
  9.  fpc conflicts with fp-compiler
  10.   fp-compiler (version 3.0.0+dfsg-2) is present and installed.
  11.   fp-compiler-3.0.0 provides fp-compiler and is present and installed.
  12.  
  13. dpkg: error processing archive /home/floyd/Downloads/fpc_3.0.4-2_amd64.deb (--install):
  14.  conflicting packages - not installing fpc
  15. dpkg: regarding .../fpc_3.0.4-2_amd64.deb containing fpc:
  16.  fpc conflicts with fp-compiler
  17.   fp-compiler (version 3.0.0+dfsg-2) is present and installed.
  18.   fp-compiler-3.0.0 provides fp-compiler and is present and installed.
  19.  
  20. dpkg: error processing archive /home/floyd/Downloads/fpc_3.0.4-2_amd64.deb (--install):
  21.  conflicting packages - not installing fpc
  22. dpkg: regarding .../fpc_3.0.4-2_amd64.deb containing fpc:
  23.  fpc conflicts with fp-compiler
  24.   fp-compiler (version 3.0.0+dfsg-2) is present and installed.
  25.   fp-compiler-3.0.0 provides fp-compiler and is present and installed.
  26.  
  27. dpkg: error processing archive /home/floyd/Downloads/fpc_3.0.4-2_amd64.deb (--install):
  28.  conflicting packages - not installing fpc

I do NOT want to reinstall my OS to fix this. But that's all I know to do. Does someone know how I can install fpc 3.0.4-2 without doing that?
« Last Edit: April 07, 2018, 02:31:08 pm by Landslyde »
Linux Mint 19
Lazarus 1.8.4
FPC 3.0.4

Handoko

  • Hero Member
  • *****
  • Posts: 2456
  • My goal: build my own game engine using Lazarus
Re: Need Help Installing FPC
« Reply #1 on: April 07, 2018, 02:07:06 pm »

Landslyde

  • Full Member
  • ***
  • Posts: 163
Re: Need Help Installing FPC
« Reply #2 on: April 07, 2018, 02:30:46 pm »
BAM!! Worked like a charm! A million thanks, Handoko.
Linux Mint 19
Lazarus 1.8.4
FPC 3.0.4

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus