* * *

Author Topic: [lamw]gtk2cellrenderer.pas(30,3) Fatal: Cannot find unit gtk2 used by Gtk2CellRe  (Read 635 times)

Luigi

  • New member
  • *
  • Posts: 26
Hello,
   I'm building my project but I'm wrong because I put a normal lazarus component, TIniStorage, on form. Now when I compile project (from "[lamw] build Android apk and run" menu)  I get ever the error in Subject!

I do not be able to understand what I do to repair my project. Must I recreate my project from start?

Can anyone help me?

Thanks.

Best regards

Luigi

  • New member
  • *
  • Posts: 26
I get the error even I delete the normal component TIniStorage.

jmpessoa

  • Hero Member
  • *****
  • Posts: 1121


Hi Luigi,

This is a symptom tha TIniStorage is LCL  dependent!  [LAMW dont support LCL components... sorry]

So,  you need drop this component an clear your "uses" section ...    // <<----- here!!!!

You can try LAMW component "jPreferences"  ....
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

Luigi

  • New member
  • *
  • Posts: 26

This is a symptom tha TIniStorage is LCL  dependent!  [LAMW dont support LCL components... sorry]
Ok, that, now, I understand  :(

Quote
So,  you need drop this component an clear your "uses" section ...    // <<----- here!!!!
It is not enough drops this component and clear "uses". I just discovered that Lazarus inserts the LCL package into the projects uses that i view on project analizer.
To repair the project is it necessary even drops the LCL package from the project's uses.

Quote
You can try LAMW component "jPreferences"  ....
Ok.

Thanks.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus