* * *

Author Topic: starting version of build fpc  (Read 980 times)

baldzhang

  • New member
  • *
  • Posts: 21
starting version of build fpc
« on: March 06, 2018, 09:10:00 pm »
I'm using fpc package build by myself, currently version is 3.0.4

after some environment change, I need a rebuild and re-package,
but got error message said 3.0.2 needed.

I didn't want to re-install an old version to do this building.

so, the question is:
If i just modify the Makefile and change REQUIREDVERSION to 3.0.4, is this ok to build fpc?

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6424
Re: starting version of build fpc
« Reply #1 on: March 06, 2018, 09:30:38 pm »
Yes. You can also simply use

make ...  OVERRIDEVERSIONCHECK=1

baldzhang

  • New member
  • *
  • Posts: 21
Re: starting version of build fpc
« Reply #2 on: March 06, 2018, 09:54:24 pm »
make ...  OVERRIDEVERSIONCHECK=1

building passed, thank you very much  :D

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus