* * *

Author Topic: KMemo 1.7.1 - no registered components  (Read 223 times)

RedOctober

  • Full Member
  • ***
  • Posts: 102
KMemo 1.7.1 - no registered components
« on: February 13, 2018, 05:58:24 pm »
Platform:  Windows Server Essentials 2016, Lazarus 1.8.1, FPC 3.0.5

The v1.7 KControls won't compile unless I manually include the LazUTF8 unit in all the "K" units that need a UTF8 function.  I was able to get the v1.7 to compile and install and I could see the K components on my pallet.  However, I decided to uninstall my v1.7 then download and install the latest version v1.7.1.  It comes with a .lpk file, but inside, Lazaras warns that there are no "Register" statements, so, it wd result in just bloating my Lazarus .exe and the components would not show up.  This is the case now. 

My question is... is there a text file that I can just add the "Register" statements to, to make the components register?  How can I get the latest KControls into my Lazarus?

Thanks in advance for any help you can provide.

CM630

  • Hero Member
  • *****
  • Posts: 753
  • Не съм сигурен, че те разбирам.
    • http://sourceforge.net/u/cm630/profile/
Re: KMemo 1.7.1 - no registered components
« Reply #1 on: February 13, 2018, 06:53:57 pm »
Did you check here: http://tkweb.eu/en/delphicomp/ ?
Simalar issues are discussed several times, I have got the impression that there are problems with RCs, but not with regular releases of Lazarus. I do not know what is 1.8.1.
Лазар 1,8,0;W7 64bit or XP 32bit;FPC3,0,4;rev 56594

RedOctober

  • Full Member
  • ***
  • Posts: 102
Re: KMemo 1.7.1 - no registered components
« Reply #2 on: February 13, 2018, 07:15:03 pm »
Hi CM630.  Yes, the website you posted is the one I downloaded the v1.7 from.  Because of the missing LazUTF8 units in the "uses" clause, I thought I'd try out the latest version from their bitbuckt link.  I have posted a question on the author's web page.

CM630

  • Hero Member
  • *****
  • Posts: 753
  • Не съм сигурен, че те разбирам.
    • http://sourceforge.net/u/cm630/profile/
Re: KMemo 1.7.1 - no registered components
« Reply #3 on: Today at 07:33:59 am »
Did you solve your issues? Exactly which component of TGrid do you intend to use?
« Last Edit: Today at 08:12:15 am by CM630 »
Лазар 1,8,0;W7 64bit or XP 32bit;FPC3,0,4;rev 56594

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus