* * *

Author Topic: [SOLVED] HTMLViewer corrupts my Lazarus installation  (Read 928 times)

JD

  • Hero Member
  • *****
  • Posts: 1703
[SOLVED] HTMLViewer corrupts my Lazarus installation
« on: February 10, 2018, 02:57:57 pm »
Hi there everyone,

I'm trying to install HTMLViewer 11.8 on Windows (I used the OPM) in my Lazarus installation. I was able to compile the package but while rebuilding Lazarus, I get an error saying Unknown/Unsupported Targa image type (see screenshot). The resulting Lazarus IDE then missing the everything except the menu bar and the component bar. In addition, clicking on the HTMLViewer palette displays the same error again.

Has anyone had similar issues with HTMLViewer?

Cheers,

JD
« Last Edit: February 10, 2018, 04:12:27 pm by JD »
Windows (10, 7) - Lazarus 1.8/FPC 3.0.4, NewPascal, Delphi
Linux Mint Cinnamon  - Lazarus 1.8/FPC 3.0.4, NewPascal

Indy 10.6 series; mORMot; Zeos 7.2.1; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

wp

  • Hero Member
  • *****
  • Posts: 4509
Re: HTMLViewer corrupts my Lazarus installation
« Reply #1 on: February 10, 2018, 03:05:41 pm »
There are several HTMLViewers out there. Which one did you install? The one which is distributed by Online Package Manager is working fine for me (Win 10), I am using Laz 32-bit though, you too?
« Last Edit: February 10, 2018, 03:12:56 pm by wp »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

taazz

  • Hero Member
  • *****
  • Posts: 5053
Re: HTMLViewer corrupts my Lazarus installation
« Reply #2 on: February 10, 2018, 03:18:48 pm »
its not the htmlviewer that "corrupts" your installation it is the Images4lazarus or something along those lines. Specificaly the tga support of that package since tga files have no ID fields on the header they rely on failing to load to decide if an image is a targa or not, by that time the mechanism has already been informed that the image is a tga an no other classes are queried for support. either remove the targa registration or the images4lazarus  package.
Good judgement is the result of experience … Experience is the result of bad judgement.

OS : Windows 7 64 bit
Laz: Lazarus 1.4.4 FPC 2.6.4 i386-win32-win32/win64

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6174
Re: HTMLViewer corrupts my Lazarus installation
« Reply #3 on: February 10, 2018, 03:19:16 pm »
Maybe misses "images for lazarus"  package or a dependence on it? Afaik those are the additional image format readers?

JD

  • Hero Member
  • *****
  • Posts: 1703
Re: HTMLViewer corrupts my Lazarus installation
« Reply #4 on: February 10, 2018, 03:31:29 pm »
There are several HTMLViewers out there. Which one did you install? The one which is distributed by Online Package Manager is working fine for me (Win 10), I am using Laz 32-bit though, you too?

I installed it from the OPM
Windows (10, 7) - Lazarus 1.8/FPC 3.0.4, NewPascal, Delphi
Linux Mint Cinnamon  - Lazarus 1.8/FPC 3.0.4, NewPascal

Indy 10.6 series; mORMot; Zeos 7.2.1; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

wp

  • Hero Member
  • *****
  • Posts: 4509
Re: HTMLViewer corrupts my Lazarus installation
« Reply #5 on: February 10, 2018, 03:48:15 pm »
its not the htmlviewer that "corrupts" your installation it is the Images4lazarus or something along those lines. Specificaly the tga support of that package since tga files have no ID fields on the header they rely on failing to load to decide if an image is a targa or not, by that time the mechanism has already been informed that the image is a tga an no other classes are queried for support. either remove the targa registration or the images4lazarus  package.
I added "Images4Lazarus" to Laz 1.8 onto which I had previously installed HTMLViewer. Again not problem, no errors while the IDE compiles.

I remember that I had seen the "Unknown/Unsupported Targa image type" recently, I forgot the details, maybe during my work with the DelphiMoon, LazBarCodes or SysTools packages. JD, are any of these packages installed on your system?
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

JD

  • Hero Member
  • *****
  • Posts: 1703
Re: HTMLViewer corrupts my Lazarus installation
« Reply #6 on: February 10, 2018, 03:50:42 pm »
its not the htmlviewer that "corrupts" your installation it is the Images4lazarus or something along those lines. Specificaly the tga support of that package since tga files have no ID fields on the header they rely on failing to load to decide if an image is a targa or not, by that time the mechanism has already been informed that the image is a tga an no other classes are queried for support. either remove the targa registration or the images4lazarus  package.
I added "Images4Lazarus" to Laz 1.8 onto which I had previously installed HTMLViewer. Again not problem, no errors while the IDE compiles.

I remember that I had seen the "Unknown/Unsupported Targa image type" recently, I forgot the details, maybe during my work with the DelphiMoon, LazBarCodes or SysTools packages. JD, are any of these packages installed on your system?

I have Images4Lazarus and LazBarCodes installed. I'll remove them and try again.

JD
Windows (10, 7) - Lazarus 1.8/FPC 3.0.4, NewPascal, Delphi
Linux Mint Cinnamon  - Lazarus 1.8/FPC 3.0.4, NewPascal

Indy 10.6 series; mORMot; Zeos 7.2.1; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

JD

  • Hero Member
  • *****
  • Posts: 1703
Re: HTMLViewer corrupts my Lazarus installation
« Reply #7 on: February 10, 2018, 04:01:23 pm »
I now installs as expected. Thanks to everyone who replied to this thread.

JD
Windows (10, 7) - Lazarus 1.8/FPC 3.0.4, NewPascal, Delphi
Linux Mint Cinnamon  - Lazarus 1.8/FPC 3.0.4, NewPascal

Indy 10.6 series; mORMot; Zeos 7.2.1; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

wp

  • Hero Member
  • *****
  • Posts: 4509
Re: HTMLViewer corrupts my Lazarus installation
« Reply #8 on: February 10, 2018, 04:09:36 pm »
If I add LazBarCodes I still don't get the crash, even if I do a clearn rebuild of the IDE...

JD, could you add Images4Lazarus and LazBarCodes again and see if the issue comes back? Then remove only Images4Lazarus, rebuild, add Images4Lazarus again, rebuild, remove LazBarcodes and rebuild again. If the bug is in LazBarcodes I feel guilty and want to fix it.
« Last Edit: February 10, 2018, 04:12:36 pm by wp »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus