* * *

Author Topic: How to use Qt5 with Lazarus-IDE 1.8?  (Read 329 times)

İbrahim

  • New member
  • *
  • Posts: 11
How to use Qt5 with Lazarus-IDE 1.8?
« on: December 20, 2017, 02:17:08 pm »
Hi. I downloaded fpc-3.0.4, fpc-src and Lazarus-IDE 1.8. I installed Lazarus and when I started Lazarus-IDE, I see Lazarus is using x86_64-linux-gtk2. I want to use Qt5 for Lazarus interface. How can I do it? Thanks.

turrican

  • Full Member
  • ***
  • Posts: 117
  • Pascal is my life.
    • Homepage
Re: How to use Qt5 with Lazarus-IDE 1.8?
« Reply #1 on: December 20, 2017, 03:31:40 pm »
Hi,

Projects -> Project Options -> Additions & Overrides -> Set "Value qt5"
« Last Edit: December 20, 2017, 03:38:21 pm by turrican »

Handoko

  • Hero Member
  • *****
  • Posts: 1947
  • My goal: build my own game engine using Lazarus
Re: How to use Qt5 with Lazarus-IDE 1.8?
« Reply #2 on: December 20, 2017, 03:41:54 pm »
What turrican said is for changing the Project's widgetset. For changing the IDE's widgetset you need to change the setting here:
Lazarus main menu > Tools > Configure "Build Lazarus"

For Qt5, you may fail on first attempt. Because you need to prepare the binding as mentioned here:
http://wiki.lazarus.freepascal.org/Roadmap#General_status_of_LCL_interfaces

You may need to search the web for how to do Qt5 binding.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus