* * *

Author Topic: [SOLVED] Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?  (Read 4649 times)

Mr.Paul

  • New member
  • *
  • Posts: 29
  • 一次编写,到处编译
I want to know, in addition to three deb package files, but also other operations? I have encountered a mistake. %)
OS: ubuntu  LTS 16.04.3 desktop zh.CN_UTF-8
fpc_3.0.4-1_amd64.deb         23,190 KB
fpc-src_3.0.4-1_amd64.deb   23,067 KB
lazarus-project_1.8.0-0_amd64.deb  88,992 KB

I could not find Lazarus 1.8 in the ubuntu repository, and then I downloaded three debs from the sf.net site, but when installing the first fpc, gdebi prompts the error "fpc conflict with fpc ()"-- This is what I translated from Chinese may not be the original English text. Eventually failed to install Lazarus.
(有人安装最新的Lazaru 1.8在ubuntu 16.04上吗?)
« Last Edit: January 10, 2018, 02:21:56 pm by Mr.Paul »

Thaddy

  • Hero Member
  • *****
  • Posts: 6556
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #1 on: December 13, 2017, 10:36:59 am »
What does whereis say? Maybe you have multiple FPC's
Ada's daddy wrote this:"Fools are my theme, let satire be my song."

andresayang

  • New member
  • *
  • Posts: 32
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #2 on: December 13, 2017, 10:52:20 am »
I want to know, in addition to three deb package files, but also other operations? I have encountered a mistake. %)
OS: ubuntu  LTS 16.04.3 desktop zh.CN_UTF-8
fpc_3.0.4-1_amd64.deb         23,190 KB
fpc-src_3.0.4-1_amd64.deb   23,067 KB
lazarus-project_1.8.0-0_amd64.deb  88,992 KB

I could not find Lazarus 1.8 in the ubuntu repository, and then I downloaded three debs from the sf.net site, but when installing the first fpc, gdebi prompts the error "fpc conflict with fpc ()"-- This is what I translated from Chinese may not be the original English text. Eventually failed to install Lazarus.
(有人安装最新的Lazaru 1.8在ubuntu 16.04上吗?)

Hi,

I have exactly the same "error" on Debian 9. This arror start to show up with Lazarus 1.8 RC2 (I was on Debian 8), I do not see it before.
I do not know what exactly the error mean, I think there is a problem somewhere in the post install script of the package.
However, fpc 3.04 is correctly installed and works perfectly.

The error does not depend of a previous install of fpc/lazarus as I try both "unclean" and "clean" install. In both case the error popups.

Cheers
Linux, Debian 9
Lazarus: always latest release

Mr.Paul

  • New member
  • *
  • Posts: 29
  • 一次编写,到处编译
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #3 on: December 13, 2017, 11:07:23 am »
I have exactly the same "error" on Debian 9. This arror start to show up with Lazarus 1.8 RC2 (I was on Debian 8), I do not see it before.
I do not know what exactly the error mean, I think there is a problem somewhere in the post install script of the package.
However, fpc 3.04 is correctly installed and works perfectly.

The error does not depend of a previous install of fpc/lazarus as I try both "unclean" and "clean" install. In both case the error popups.
so, how can I make it "perfect work"?  Now simply can not complete the installation, urgent ah!

Mr.Paul

  • New member
  • *
  • Posts: 29
  • 一次编写,到处编译
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #4 on: December 13, 2017, 11:08:49 am »
only one FPC.   Newly installed ubuntu.
What does whereis say? Maybe you have multiple FPC's

Thaddy

  • Hero Member
  • *****
  • Posts: 6556
Ada's daddy wrote this:"Fools are my theme, let satire be my song."

andresayang

  • New member
  • *
  • Posts: 32
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #6 on: December 13, 2017, 12:54:38 pm »
I have exactly the same "error" on Debian 9. This arror start to show up with Lazarus 1.8 RC2 (I was on Debian 8), I do not see it before.
I do not know what exactly the error mean, I think there is a problem somewhere in the post install script of the package.
However, fpc 3.04 is correctly installed and works perfectly.

The error does not depend of a previous install of fpc/lazarus as I try both "unclean" and "clean" install. In both case the error popups.
so, how can I make it "perfect work"?  Now simply can not complete the installation, urgent ah!

Did you try, in a shell: sudo dpkg -i "package.deb" ?
Linux, Debian 9
Lazarus: always latest release

Handoko

  • Hero Member
  • *****
  • Posts: 2447
  • My goal: build my own game engine using Lazarus
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #7 on: December 13, 2017, 02:02:08 pm »
@Mr.Paul

I have no problem installing Lazarus on Ubuntu Mate 17.10 (current latest version). I ever had problem installing Lazarus on older version of Ubuntu, which I solved by using version locking. If I'm not wrong Ubuntu (or maybe Linux) will prevent you to install Lazarus if the FPC version is higher than in its repository. By version locking the FPC and FPC-source, the Lazarus can be installed.

Read more here:
http://forum.lazarus.freepascal.org/index.php/topic,39281.msg269012/topicseen.html#new

Mr.Paul

  • New member
  • *
  • Posts: 29
  • 一次编写,到处编译
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #8 on: December 13, 2017, 04:08:41 pm »
@Handoko
Thanks for your attention and experiment!  Your experimental success is good news for me.

I noticed the difference between our experimental environment,  what you did was the second Lazarus on ubuntu mate 17 and what I did was a brand new installation of Lazarus on ubuntu LTS 16.04.
You have used "version locking" to solve the installation problem on the old version of Ubuntu, I decided to test immediately. Hope tonight there is good news.

mig-31

  • Full Member
  • ***
  • Posts: 233
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #9 on: December 13, 2017, 04:24:59 pm »
Never hear about version prevention on any Linux.

But you can force deb or rpm package installation (yum, rpm, urpmi, apt-get) on any Linux distribution.
Lazarus 1.6 - Linux 32/64 bit, win32

Handoko

  • Hero Member
  • *****
  • Posts: 2447
  • My goal: build my own game engine using Lazarus
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #10 on: December 13, 2017, 04:51:42 pm »
But you can force deb or rpm package installation (yum, rpm, urpmi, apt-get) on any Linux distribution.

Yes, you're right. Actually we do not need to force install, to install higher (or lower) version of the same app. But the problem is, it sometimes may refuse to let you to install Lazarus. At least it happened on my tests.

Here, the whole story.

I tested at least 3 times, the results were same. I cannot remember the full detail because those tests were performed long ago.

I used Gdebi instead of sudo dpkg. The installation of FPC and FPC-source were success, although the version I installed was higher than the version recommended in my Ubuntu repository.

But when I used Gdebi to install the Lazarus deb package, the "install" button was greyed, I cannot click to continue. I checked using Synaptic Package Manager, both FPC and FPC-source were correctly installed.

After some random testings, I found simply version lock both the FPC and FPC-source, the disabled "install" button when installing Lazarus became available.

Maybe now, things have been changed. But no harm to test version lock.
« Last Edit: December 13, 2017, 04:58:46 pm by Handoko »

Handoko

  • Hero Member
  • *****
  • Posts: 2447
  • My goal: build my own game engine using Lazarus
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #11 on: December 13, 2017, 05:12:57 pm »
I could not find Lazarus 1.8 in the ubuntu repository, and then I downloaded three debs from the sf.net site, but when installing the first fpc, gdebi prompts the error "fpc conflict with fpc ()"

Was the version conflict message you get looks similar to what I got (see picture below)? Did that message appear after the installation of the fpc deb package?

If the answer is yes, simply ignore it. The message appears after the installation finished and it really installed correctly. That message is misguiding. I consider it is a bug. It sometimes happens but sometimes does not happen when I installing FPC. Nothing bad ever happened after I ignore that message.
« Last Edit: December 13, 2017, 05:14:51 pm by Handoko »

Mr.Paul

  • New member
  • *
  • Posts: 29
  • 一次编写,到处编译
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #12 on: December 13, 2017, 06:44:00 pm »
I have no problem installing Lazarus on Ubuntu Mate 17.10 (current latest version). I ever had problem installing Lazarus on older version of Ubuntu, which I solved by using version locking. If I'm not wrong Ubuntu (or maybe Linux) will prevent you to install Lazarus if the FPC version is higher than in its repository. By version locking the FPC and FPC-source, the Lazarus can be installed.
Failed. :-\
In Ubuntu 16.04.3 tried a variety of ways, gdebi, synatic, fpc3.0.4, fpc3.0.2 ...... version locking may be not properly used. The environment has been disrupted and no conclusion can be drawn.
I'm tired……

Mr.Paul

  • New member
  • *
  • Posts: 29
  • 一次编写,到处编译
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #13 on: December 13, 2017, 07:01:27 pm »
Was the version conflict message you get looks similar to what I got (see picture below)? Did that message appear after the installation of the fpc deb package?
Yes, I have the same error message you encountered, "fpc conflict fpc ()". The error occurred in fpc 3.0.4 and did not show up in fpc-src 3.0.4.
However, after being ignored, in gdebi, the installation of Lazarus deb reports "failed" and no visible Lazarus icon at all.

docno

  • New member
  • *
  • Posts: 15
Re: Did anyone install the latest Lazaru 1.8 on ubuntu 16.04?
« Reply #14 on: December 13, 2017, 08:24:25 pm »
Installed on my chromebook acer running GALLIUM OS (ubuntu).
I have the fpc conflict but the install is complete and i can compile my apps.


 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus