* * *

Author Topic: slackware and deb and rpm not working to get Lazarus 1.8 installed  (Read 672 times)

userx-bw

  • Full Member
  • ***
  • Posts: 178


Code: [Select]
userx@slackwhere:~/Downloads
$ rpm2tgz lazarus-1.8.0-0.x86_64.rpm
ERROR:  rpm2cpio failed.  (maybe lazarus-1.8.0-0.x86_64.rpm is not an RPM?)
userx@slackwhere:~/Downloads
$ deb2tgz fpc-src_3.0.4-1_amd64.deb
mv: cannot stat 'data.tar.gz': No such file or directory
ERROR:  ar failed. (maybe fpc-src_3.0.4-1_amd64.deb is not an DEB?)
so makes me wonder what differences are now being made to deb and rpm's that the program to convert them to tgz is not working on them?
My Finished Projects
https://sourceforge.net/projects/mhsetroot/
https://sourceforge.net/projects/gmhsetrootfreepascalfrontend/

HP Elitetbook 6930p Dual Core Intel vPro 2.66 gHz
VOID (Linux) 64bit

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3358
  • I like bugs.
Re: slackware and deb and rpm not working to get Lazarus 1.8 installed
« Reply #1 on: December 11, 2017, 04:12:14 pm »
Forget the DEB and RPM packages. They seem to cause trouble even is systems which claim to support them. I bet they cause more trouble in Slackware.
Just install FPC using the package + install script provided by FPC project. It works in any Unix related system.
Then get Lazarus 1.8 from SVN fixes branch and build it. As an extra bonus you get the latest bug fixes always with "svn up".
In your home dir or in any writable place:
$ svn co https://svn.freepascal.org/svn/lazarus/branches/fixes_1_8 lazarus_1_8
$ cd lazarus_1_8
$ make
$ ./lazarus

BeanzMaster

  • Jr. Member
  • **
  • Posts: 87
Re: slackware and deb and rpm not working to get Lazarus 1.8 installed
« Reply #2 on: December 11, 2017, 09:58:46 pm »
Hello it seems with Linux Lazarus installation have some problems it's the same on Mageia 64 bits (RPM) and  Mint 64 bits (DEB)

Message translated from https://www.developpez.net/forums/d1786555/autres-langages/pascal/lazarus/l-edi-lazarus-1-8-disponible-retard-fort-serieuses-ameliorations/#post9840211

Quote
I can not run this version 1.8 on Linux, and I have the same problem with Mageia 64 bit (installed with RPM packages) and with Mint 64 bit (DEB packages): link editing is not possible ( I checked the platform options, etc.).

If I install FPC 3.0.4 alone, downloaded on freepascal.org, compiling and linking is done worry free.
If I add the downloaded Lazarus 1.8.0 package to SourceForge, then the expected version of FPC is not the right one (it wants 3.0.4 release 1). OK, let's give him the right version. I uninstall version 3.0.4.

I'm now installing version 3.0.4.1 alone, available with Lazarus 1.8: link editing does not work - with a very terse error message 'Error while linking'. Lazarus installs without problems later, but hey without being able to edit the links, I'm stuck.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus