* * *

Author Topic: Warning after installing lazarus-1.6.4-fpc-3.0.2-cross-i386-win32-win64.exe  (Read 379 times)

antispam88

  • New member
  • *
  • Posts: 11
Hi!

I don't know if this is the right place, but I will have a try.
I installed above file on my Win 10 Ent x64 system and getting this message when I select a i386 target:
The current FPC has no config file. It will probably miss some units. Check your installation of fpc.

But when I compile to that target I'm getting a running exe.

So is this message obsolete? Or how can I fix this?

Best regards,
antispam88

lazarus-1.6.4-fpc-3.0.2-win64.exe

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4416
    • wiki
Did you install
lazarus-1.6.4-fpc-3.0.2-win64.exe (message body of your post)
or
lazarus-1.6.4-fpc-3.0.2-cross-i386-win32-win64.exe  (subject of your post)
?

The latter will only work, if you also install the former. (and the former must be installed first, and both in the same folder)

------------------------
If you did install lazarus-1.6.4-fpc-3.0.2-win64.exe
(and optionally the cross installer too)


- What path/folder did you install too?
- In Tools menu > Options: Does the path to fpc point to
  <install dir>\fpc\3.0.2\bin\i386-win32\fpc.exe (or similar)
- Does that folder have a file  fpc.cfg ?

If you did install the cross installer too:
- Did the error happen when only the lazarus-1.6.4-fpc-3.0.2-win64.exe was installed (without the cross installer)? Or did adding the cross installer introduce the error?

When you select " i386 target", do you also select target OS: win32 ?

-----------
Did any error happen at the end of the install?

The installer should have created that file.

To do so the installer runs fpcmkcfg.exe after the install (the file is part of the install).

If the file is missing, I can only think that maybe your antivirus or windows defender may have interfered.

Or maybe the name of the folder caused a problem. I am not aware of anything in any folder name that would cause an issue, but one never knows.

Try running
Code: [Select]
cd <install dir>\fpc\3.0.2\bin\i386-win32
<install dir>\fpc\3.0.2\bin\i386-win32\fpcmkcfg.exe -d "basepath=<install dir>\fpc\3.0.2\" -o "<install dir>\fpc\3.0.2\bin\i386-win32\fpc.cfg"

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5875
(maybe we should simply change "cross" in the filenames to cross.addon.)

antispam88

  • New member
  • *
  • Posts: 11
Thank you for your quick reply.

@Martin_fr
Yes I did it the way you described and installed both into the same directory (C:\lazarus).

The fpc points to "C:\lazarus\fpc\3.0.2\bin\x86_64-win64\fpc.exe". Should this change when selecting a target with i386 cpu?

In the directory C:\lazarus\fpc\3.0.2\bin there is only a x86_64-win64 dir. This dir contains a fpc.cfg.

The message appears since the cross compiler is installed and when I change from a target with x86_64 cpu to one with i386.

No, I only have set the cpu.

While installing I didn't noticed any error and it quit with a success message.

I can't try your instruction because I don't have this path :-(.


Best regards,
antispam88

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4416
    • wiki
The fpc points to "C:\lazarus\fpc\3.0.2\bin\x86_64-win64\fpc.exe". Should this change when selecting a target with i386 cpu?
No do not change. This is correct. I wrote the example incorrect.

Quote
In the directory C:\lazarus\fpc\3.0.2\bin there is only a x86_64-win64 dir. This dir contains a fpc.cfg.
No, I only have set the cpu.
Leave all the path as they are.

But try to also change the target OS to win32.  (Though this may not be the problem)

-------------------
To be sure:
So you can still compile for 64  bit without error?

-------------------
You get the error trying for 32 bit.

Does the error happen
a) when you change the target, and press ok in the project options
b) when you compile (F9)

In case of b)
add to custom option (in project options) -va
Start to compile

when you get the error, right click the messages window, and "Copy" > "Copy all/original messages..."
This may be big, so save to a file and attach.

antispam88

  • New member
  • *
  • Posts: 11
As I mentioned in the first post:
I can compile the i386 target and the exe is working as well.

And your hint with the target os is preventing the warning message (see attachment). So does this mean I have to set up build modes for all variations of os's and cpu's we use? Or is there another option to prevent the message.

Yes, the warning message appears right after pressing ok in the project options or direct after changing when using "Change build mode" control.
I searched the whole message window for errors but didn't find any. I found only these hints: "Free Pascal Compiler version 3.0.2 [2017/02/26] for i386".

Best regards,
antispam88

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4416
    • wiki
Ok, so its the IDE/codetools that dont find it.
I'd say your installation is ok.

I dont know any easier way to prevent the warning. If FPC compiles i386/ OS=default, then I guess the IDE is wrong with that warning.

It may be fixed in 1.8 (just released now). Otherwise it may be worth reporting.

antispam88

  • New member
  • *
  • Posts: 11
I just tested it with 1.8 without luck :-(
Same behaviour as with 1.6.4.

Shall I report that? If so, is there an HOWTO for that?

Best regards,
antispam88

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus