* * *

Author Topic: Lazarus 1.8.0_fixes SVN 56450 - TDataSet.Params problem in IDE  (Read 642 times)

ertank

  • Full Member
  • ***
  • Posts: 168
Lazarus 1.8.0_fixes SVN 56450 - TDataSet.Params problem in IDE
« on: November 21, 2017, 10:57:30 am »
Hello,

I am suggested to discuss the problem in the forum first.

On Raspberry Pi 3, Stretch, I am having problem of parameters are not updated after set once. Which means. They work OK for the first time. If I am to modify SQL and add/remove a parameter, IDE cannot show them in "Editing SQLQuery1.Params" window.

I tried to put together a screen capture video. I know it's quality is low, but I hope it explains the problem better than written.
Link: http://s4.dosya.tc/server5/iabdr8/screencapture.mkv.html

This problem I can reproduce on subject SVN version in fixes_1_8 branch. I also confirm same problem exists on 1.80RC5 release latest SVN sources.

I appreciate any feedback.

Thanks & regards,
Ertan

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3328
  • I like bugs.
Re: Lazarus 1.8.0_fixes SVN 56450 - TDataSet.Params problem in IDE
« Reply #1 on: November 21, 2017, 01:33:01 pm »
You had a bug report about it:
 https://bugs.freepascal.org/view.php?id=32705
See my comment there. Maybe LacaK can explain more.
Somebody should take over the database related stuff. There is no active maintainer. I don't personally do much DB programming and don't know the details.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus