* * *

Author Topic: Raspberry Pi Zero W Lazarus installation fails  (Read 1348 times)

amarryat

  • New member
  • *
  • Posts: 12
Raspberry Pi Zero W Lazarus installation fails
« on: November 20, 2017, 09:02:28 pm »
After realizing I posted this originally in the Programming section, I should have posted it here:


I am unable to install the version from GetLazarus.org using the setup.sh file they have.

The script fails at lazarus/lazbuild with an EAccessViolation.

I am able to install it using sudo apt-get lazarus.  However that is an older version and there are bugs that my compiled program exhibits because of this.

I was able to install the GetLazarus.org version on the Raspberry Pi Model 3B and it works just fine.  Why is there an EAccessViolation when I'm going the exact same procedure on the Zero W?

BTW, I increased the swap file size to 1024 on the Zero W hoping that would fix things but it had no effect.

Thaddy

  • Hero Member
  • *****
  • Posts: 6880
Re: Raspberry Pi Zero W Lazarus installation fails
« Reply #1 on: December 13, 2017, 10:50:21 am »
it is better to install an official distribution. There is a pre-build official fpc 3.0.4 distribution available for the raspberry pi 1 here ftp://freepascal.stack.nl/pub/mirrors/fpc/dist/3.0.4/arm-linux/fpc-3.0.4.arm-linux-eabihf-raspberry.tar.
Make sure you have installed subversion: sudo apt-get update && sudo apt-get install subversion -y
Simply tar -xf and run sudo sh install.sh or sudo ./install.sh.
After that check out the lazarus sources: cd ~/ && svn co https://svn.freepascal.org/svn/lazarus/tags/lazarus_1_8_0 lazarus and do
make all (or make bigide if you have swapspace, I did not try that, you can always install more packages later) in the lazarus directory.
Start lazarus, install packages you want, e.g. the anchordocking packages, save, exit and do a make useride.

Ready.

This works on my Raspberry Pi zero. For some packages there may be some dependencies missing, so you should install those by hand when necessary.
If you have installed and simply uninstalled (no purge and autoremove) an older version of fpc from the Raspbian repository, the dependencies should all be installed already.

This package is build for armv6 eabihf. (zero, 1 and older 2, will work on newer 2 and RPi3, though)
For RPi 3 and newer 2 there is a separate package built for ARMv7 eabihf.
« Last Edit: December 13, 2017, 11:18:58 am by Thaddy »
Ada's daddy wrote this:"Fools are my theme, let satire be my song."

chrnobel

  • Full Member
  • ***
  • Posts: 222
Re: Raspberry Pi Zero W Lazarus installation fails
« Reply #2 on: September 17, 2018, 05:51:17 pm »
For RPi 3 and newer 2 there is a separate package built for ARMv7 eabihf.
Hi Thaddy.

Where can that package be found?

Thanks
Christian

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus