* * *

Author Topic: A report about cause and solution of the error: "Panic: Makefile:29: *** You nee  (Read 435 times)

GutBr

  • Newbie
  • Posts: 1
25/08/2017
A report about cause and solution of the error: "Panic: Makefile:29: *** You need the GNU utils package to use this Makefile.  Stop."

Problem summary: This error occur during the Lazarus'  IDE rebuilding process and avoid this rebuilding and, consequently, the new packages installation. Used file: lazarus-1.6.4-fpc-3.0.2-win32.exe

Observed contexts:

1. installation: Lazarus 1.6.4-fpc-3.0.2-win32 on WinXP  like “a single Lazarus' installation"
  - It have no problems with rebuilding Lazarus IDE.
 
2.  installation: Lazarus 1.6.4-fpc-3.0.2-win32 on Win10 64 Bits like “a second lazarus' installation
- It seems work well because a new project is compiled normally.
- However, the IDE isn't rebuilding and the follow error message appear::

   Build IDE: Exit code 2, Errors: 4
   Panic: make: Entering directory `C:/lazarus[1.6.4]'
   Panic: make: Leaving directory `C:/lazarus[1.6.4]'
   Panic: Makefile:29: *** You need the GNU utils package to use this Makefile.  Stop.
   Panic: tool stopped with exit code 2. Use context menu to get more information.

After a lot of research, unsuccessful attempts and after I have read Lazarus FAQ, I realized that there is a similar error in function of the presence of spaces into the Lazarus' directory path. This is the message:

   makefile:27: *** You need the GNU utils package to use this Makefile. Stop.
   Make sure you didn't install FPC in a path with spaces in the name. The Makefile doesn't support it.
   
Origem:[http://wiki.lazarus.freepascal.org/Lazarus_Faq#What_is_Lazarus.3F]
 
I beleave that the path used by me (C:\lazarus[1.6.4]), with “[" and "]”, can have caused the problem.
Solution: I've uninstalled Larazus program e reinstalled this second installation with de follow paths:
   C:\lazarus-1.6.4
   C:\lazarus-1.6.4\0\Config
With this changes, the rebuilding worked again.

Conclusions:
1. The Make program, used to rebuilding Lazarus IDE, is sensitive to spaces and different caracters like "[", "]" into the Lazarus' directory path .
2. Using this last two characters, this program give to us the follow errors messages:

   Build IDE: Exit code 2, Errors: 4
   Panic: make: Entering directory `C:/lazarus[1.6.4]'
   Panic: make: Leaving directory `C:/lazarus[1.6.4]'
   Panic: Makefile:29: *** You need the GNU utils package to use this Makefile.  Stop.

3.When the name of Lazarus' directory is according the rules of Make program, it insert into Lazarus IDE configurations (IDE Options, into [Tools/Options/<Environment><"Make" executable>]) the follow information:

   $Path($(CompPath))make.exe (With variables)

4. When the name of Lazarus' directory isn't accordin the rules of Make program, it inserts, into Lazarus IDE configurations, the follow information:

   C:\lazarus[1.6.4]\fpc\3.0.2\bin\i386-win32\make.exe (complete path, without variables)

5. Similar problems can cause similar errors mensages, like erros #29 and #27 reported here.

I know that this was a simple problem but I spent a lot of time of research to arrive in this informations and solution. I hope them be useful to other people with the some similar problem.


marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5809
Some tips:

1. clean out your %PATH%, and make sure that FPC/Lazarus is the only package in there that packs Unix style commands.
2. Use a supported Windows version. (XP is out of support for more than an year).

If everything fails, avoid [ and ]. The sensibilities are in files like make that are external to the FPC/Lazarus project, and we can't fix that short term.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus