* * *

Author Topic: Debugger Mac OS 10.12.5 Lazarus 1.6.4 rexported FPC 3.0.2 i386-darwin-carbon  (Read 2230 times)

carl_caulkett

  • Full Member
  • ***
  • Posts: 243
LOL. They are identical! In any case, I am getting used to using Xcode to debug. It helps that I can still make GUI changes in Lazarus and have them instantly updated in Xcode. Obviously, this represents a mystery to be solved but it's not massively urgent. I guess we'll just have to wait for Lazarus 2.0, in which all the debugging shortcomings will have been solved!

Cheers,
Carl
macOS 10.12.6
Lazarus 1.8.0 RC4
FPC 3.0.2

Wil

  • Newbie
  • Posts: 1
Hello,

OMG, I had to much trouble getting gdb to play nice. Always got the dreaded error that my gdb was not signed.

This part of your message however was what made me realize the problem was elsewhere
Quote
unMac:~ untel$ ls -l /usr/local/bin/gdb
-r-xr-xr-x  1 untel  admin  8407456 18 jui 14:10 /usr/local/bin/gdb
unMac:~ untel$ /quote]

I had installed the fsf-gdb version of the debugger via fink and it turned out it had set the ownership of the file to defaults not under my user account.
Eg.
Quote
$ ls -al /sw/lib/fsf-gdb/fsf-gdb
-rwxr-sr-x  1 root  procmod  8792912 Jul 28 13:15 /sw/lib/fsf-gdb/fsf-gdb

Once I changed that via:
Quote
$ sudo chown myusername:admin /sw/lib/fsf-gdb/fsf-gdb

The debugger credential request login came up and things started to work.

Thank You so much for writing it out. Can't believe how long this took me to get right.

--
Wil

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus