* * *

Author Topic: Error finding unit  (Read 388 times)

dietmar

  • Jr. Member
  • **
  • Posts: 76
Error finding unit
« on: May 20, 2017, 10:46:28 am »
Hi,

I just downloaded a TreeView component.
When I try compiling the test project, I get the error:

Compile Project, Target: treelistviewexample.exe: Exit code 1, Errors: 1
interfaces.pp(27,3) Fatal: Cannot find LazUTF8 used by Interfaces, incompatible ppu=C:\lazarus\components\lazutils\lib\x86_64-win64\lazutf8.ppu, package LazUtils

I looked for LazUTF8, and its there.
My OS is Win10 with Lazarus 1.6.

Any ideas?
Thanks!

Dietmar
« Last Edit: May 20, 2017, 10:58:09 am by dietmar »
Lazarus 1.6.4 with FPC 3.0.2 on Windows10 64Bit

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3135
  • I like bugs.
Re: Error finding unit
« Reply #1 on: May 20, 2017, 10:59:11 am »
I just downloaded a TreeView component.
TreeView is included in LCL, no need to downloaded it separately.

Quote
Compile Project, Target: treelistviewexample.exe: Exit code 1, Errors: 1
interfaces.pp(27,3) Fatal: Cannot find LazUTF8 used by Interfaces, incompatible ppu=C:\lazarus\components\lazutils\lib\x86_64-win64\lazutf8.ppu, package LazUtils
The .ppu binary is compiled with another version. Maybe you installed a new Lazarus version on top of an old one.
Just build everything clean and you are good.
If a clean build of your project does not help then build the whole Lazarus.
 Tools -> Configure "Build Lazarus" ... -> Check "Clean all".
« Last Edit: May 20, 2017, 11:00:42 am by JuhaManninen »

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus