* * *

Author Topic: Lazarus Release Candidate 1 of 1.8  (Read 19401 times)

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4280
    • wiki
Lazarus Release Candidate 1 of 1.8
« on: May 17, 2017, 03:43:52 pm »
The Lazarus team is glad to announce the first release candidate of
Lazarus 1.8.

This release was built with FPC 3.0.2.
The previous release Lazarus 1.6.4 was built with FPC 3.0.2 too.
The Linux releases are built with FPC 3.0.3 r36152 due to bug
https://bugs.freepascal.org/view.php?id=31629

Here is the list of fixes for Lazarus 1.8.x:
http://wiki.freepascal.org/Lazarus_1.8_fixes_branch

Here is the list of changes for Lazarus and Free Pascal:
http://wiki.lazarus.freepascal.org/Lazarus_1.8.0_release_notes
http://wiki.lazarus.freepascal.org/User_Changes_3.0.2

The release is available for download on SourceForge:
http://sourceforge.net/projects/lazarus/files/

Choose your CPU, OS, distro and then the "Lazarus 1.8 RC1" directory.

Checksums for the SourceForge files:
http://www.lazarus-ide.org/index.php?page=checksums#1_8_0

Minimum requirements:

Windows:       
  2k, XP, Vista, 7, 8, 8.1 and 10, 32 or 64bit.

FreeBSD/Linux:
  gtk 2.8 for gtk2, qt4.5 for qt, qt5.6 for qt5, 32 or 64bit.

Mac OS X:
  10.5 to 10.12, LCL only 32bit, non LCL apps can be 64bit.

The svn tag is
http://svn.freepascal.org/svn/lazarus/tags/lazarus_1_8_0_RC1

For people who are blocked by SF, the Lazarus releases from SourceForge are mirrored at:
ftp://freepascal.dfmk.hu/pub/lazarus/releases/
and later at (after some time for synchronization)
http://mirrors.iwi.me/lazarus/

== Why should everybody (including you) test the release candidate? ==

In the past weeks the Lazarus team has stabilized the 1.8 fixes branch. The resulting 1.8RC1 is now stable enough to be used by any one for test purposes.

However many of the fixes and new features that where committed since the release of 1.6 required changes to the code of existing features too. While we have tested those ourself, there may still be problems that only occur with very specific configurations or one project in a million.

Yes, it may be that you are the only person with a project, that will not work in the new IDE. So if you do not test, we can not fix it.

Please do not wait for the final release, in order to test. It may be too late. Once the release is out we will have to be more selective about which fixes can be merged for further 1.8.x releases. So it may be, that we can not merge the fix you require. And then you will miss out on all the new features.

== How to test ==

Download and install the 1.8 RC1.
- On Windows you can install as a 2ndary install, that will not affect your current install:
  http://wiki.lazarus.freepascal.org/Multiple_Lazarus#Installation_of_multiple_Lazarus
- On other platforms, if you install to a new location you need to use --primary-config-path

In either case you should make backups. (including your primary config)

Open your project in the current Lazarus (1.6.x), and use "Publish Project" from the project menu. This creates a clean copy of your project.

You can then open that copy in the RC1. Please test:
- If you can edit forms in the designer
   - rename components / change properties in Object inspector / Add new events
   - Add components to form / Move components on form
   - Frames, if you use them
- If you can navigate the source code (e.g. jump to implementation)
- Auto completion in source code
- Compile, debug and run
- Anything else you use in your daily work


« Last Edit: June 07, 2017, 04:12:07 am by Martin_fr »

Eugene Loza

  • Sr. Member
  • ****
  • Posts: 387
    • Decoherence Studio :)
Re: Lazarus Release Canditate 1 of 1.8
« Reply #1 on: May 17, 2017, 03:53:41 pm »
COOL!!! THANKS A LOT!!!!! :D :D :D
My Free and Open Source games in Lazarus/FreePascal/CastleGameEngine:
https://decoherence.itch.io/
(and some ancient games in Turbo Pascal too)

ahiggins

  • Jr. Member
  • **
  • Posts: 57
Re: Lazarus Release Canditate 1 of 1.8
« Reply #2 on: May 17, 2017, 04:05:14 pm »
Great work, many thanks

JZS

  • Full Member
  • ***
  • Posts: 174
Re: Lazarus Release Canditate 1 of 1.8
« Reply #3 on: May 17, 2017, 04:13:24 pm »
Thanks Lazarus Developers...
I use recent stable release

knuckles

  • Jr. Member
  • **
  • Posts: 91
Re: Lazarus Release Canditate 1 of 1.8
« Reply #4 on: May 17, 2017, 05:01:54 pm »
Excellent work 8-)

tr_escape

  • Sr. Member
  • ****
  • Posts: 250
  • sector name toys
    • Github:
Re: Lazarus Release Canditate 1 of 1.8
« Reply #5 on: May 18, 2017, 08:58:37 am »
In linux mint fpc_3.0.3-r36152_i386.deb gave a error but I able to installed with by shell.
All packages install with shell command:

sudo apt deb fpc_3.0.3-r36152_i386.deb
sudo apt deb fpc-src_3.0.3-r36152_i386.deb
sudo apt deb lazarus-project_1.8.0RC1-0_i386.deb

I think (maybe) previous version and my some trying to cross compiling can be effect.

After component/package install my project compiled.

Thank a lot to Lazarus & Fpc team.

PeterX

  • Full Member
  • ***
  • Posts: 208
Re: Lazarus Release Canditate 1 of 1.8
« Reply #6 on: May 18, 2017, 09:43:40 am »
I'm on Windows.
Lazarus 32 Setup wants to write a QT4 dll into windows/system32
So Setup needs admin rights.
usually using latest Lazarus release version
with Windows 10 at home
and Windows 7 on the job

PeterX

  • Full Member
  • ***
  • Posts: 208
Re: Lazarus Release Canditate 1 of 1.8
« Reply #7 on: May 18, 2017, 10:29:10 am »
Whyever, this window was left over after installation of RC1 ..

usually using latest Lazarus release version
with Windows 10 at home
and Windows 7 on the job

jma_sp

  • Full Member
  • ***
  • Posts: 121
  • El conocimiento si ocupa lugar.
Re: Lazarus Release Canditate 1 of 1.8
« Reply #8 on: May 18, 2017, 11:21:50 am »
Muchas gracias una vez más al equipo de FreePascal sin el cual Lazarus no sería posible y al equipo de Lazarus por hacer posible una nueva versión.

Lo he instalado y me ha dado un error al compilar un programa:

Compilar paquete CodeTools 1.0.1: Código de salida 1, Errores: 1
basiccodetools.pas(42,32) Fatal: no puedo encontrar Laz_AVL_Treeutilizado por BasicCodeTools, ppu incompatible=C:\lazarus18\components\lazutils\lib\i386-win32\laz_avl_tree.ppu, paquete LazUtils
Compilar paquete IDEIntf 1.0: Abortado, Errores: 1
actionseditor.pas(29,3) Fatal: no puedo encontrar LCLIntfutilizado por ActionsEditor, ppu incompatible=C:\lazarus18\lcl\units\i386-win32\lclintf.ppu, paquete LCLBase

Supongo que es mejor que reconstruir o hacer una instalación limpia sin la versión previa pero por el momento no puedo.
Debian 8.6 - (JWM/ROX/iDesk) - Devuan (beta without systemd ) - Puppy -  Quirky 7.4 - Windows XP - ReactOS 0.4.xx  - FreeDos - OctaOS - KolibriOS

dogriz

  • Jr. Member
  • **
  • Posts: 84
    • Tech blog - Delphi, Lazarus, Firebird, Windows, Linux, Android...
Re: Lazarus Release Canditate 1 of 1.8
« Reply #9 on: May 18, 2017, 12:01:28 pm »
Tested crosscompilation (simple form with label, edit, button and checkbox) on Debian 9 (amd64)

Freepascal 3.0.3 + Lazarus 1.8 RC1

linux x86_64 (native)    OK
linux i386      OK
win32         OK
win64         OK
linux arm v7      OK

Looks promising so far. But will be tested more. Thanks for a great work!
FPC 3.0.3
Lazarus 1.6.5
Debian x86_64, arm

jma_sp

  • Full Member
  • ***
  • Posts: 121
  • El conocimiento si ocupa lugar.
Re: Lazarus Release Canditate 1 of 1.8
« Reply #10 on: May 18, 2017, 12:48:06 pm »
OK, ALL WORKS NOW, NO ERRORS, just CLEAN + REBUILD ALL.

In translation need to translate a button caption from English to  Spanish: Break to Interrumpir

De maravilla :)

« Last Edit: May 18, 2017, 12:49:46 pm by jma_sp »
Debian 8.6 - (JWM/ROX/iDesk) - Devuan (beta without systemd ) - Puppy -  Quirky 7.4 - Windows XP - ReactOS 0.4.xx  - FreeDos - OctaOS - KolibriOS

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4280
    • wiki
Re: Lazarus Release Canditate 1 of 1.8
« Reply #11 on: May 18, 2017, 01:35:04 pm »
I'm on Windows.
Lazarus 32 Setup wants to write a QT4 dll into windows/system32
So Setup needs admin rights.

There is a checkbox allowing you to choose, if you want to install the qt lib.

You only need it, if you want to write qt apps. (which I guess most people do not need)

However, yes, it is checked by default.

BBasile

  • Sr. Member
  • ****
  • Posts: 289
Re: Lazarus Release Canditate 1 of 1.8
« Reply #12 on: May 19, 2017, 01:49:28 am »
Thanks for this version but it is not good at all. On a single application i have 3 breaking changes and (or) regressions. That's way too much.

Already spent 3  hours  trying to find workarounds. Once a thing fixed i discover another new issue. great.

Regressions or breaking changes have that of annoying is that you're asked to spend some time on things you're not responsible for breaking.
« Last Edit: May 19, 2017, 02:27:58 am by BBasile »

zeljko

  • Hero Member
  • *****
  • Posts: 912
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Lazarus Release Canditate 1 of 1.8
« Reply #13 on: May 19, 2017, 09:01:44 am »
Thanks for this version but it is not good at all. On a single application i have 3 breaking changes and (or) regressions. That's way too much.

Already spent 3  hours  trying to find workarounds. Once a thing fixed i discover another new issue. great.

Regressions or breaking changes have that of annoying is that you're asked to spend some time on things you're not responsible for breaking.

That's why it's name is RC1. Please open issues about  any regressions.

BBasile

  • Sr. Member
  • ****
  • Posts: 289
Re: Lazarus Release Canditate 1 of 1.8
« Reply #14 on: May 19, 2017, 10:03:37 am »
It's a beta. I think that usually a RC is almost usable so that people can actually use it much and find problems that are not so obvious. Here for me it's very obvious: things are broken and not working. At the beginning it even did not compile.

Maybe it's just bad luck. This happens sometimes, everyone thinks it's okay while a single person have many problems.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus