* * *

Author Topic: FPSExport - limitation or problem  (Read 334 times)

dsyrios

  • New member
  • *
  • Posts: 25
FPSExport - limitation or problem
« on: March 28, 2017, 08:59:11 am »
Hi,
using FPSExport at the same DB, same table,
when I try to export all of the fields, the created file is OK
BUT there is memory leak exiting the program.
When exporting some of the fields, everything is ok.
how to avoid this?
At the same sample project, using CSVExporter, everything is ok.

Is there any limitations about the number of fields
or there is another problem?

Thanks in advance.
ps
In the attachment there is not sqlite3.dll

Laz 1.6.2/FPC 3.0.0/win32

wp

  • Hero Member
  • *****
  • Posts: 3448
Re: FPSExport - limitation or problem
« Reply #1 on: March 28, 2017, 11:28:30 am »
Can't run your demo, it keeps telling me that the file is encrypted or not a database file (which is not true because I can open it with lazdatabasedesktop). Is there anything else that I have to do in addition to copying sqlite3.dll to the exe folder?
Lazarus trunk / fpc 3.0.0 / Win32

dsyrios

  • New member
  • *
  • Posts: 25
Re: FPSExport - limitation or problem
« Reply #2 on: March 28, 2017, 11:57:20 am »
Hi again.
I solved it, but I don't know why it happened.
There are two fields
"soCheckDF" type of varchar(6) and "soEndF" type of varchar(6)
with NO default values.
Somehow the values at many records were (empty), when I updated them with (null) values,
as follow:
UPDATE [HiveT] SET [soCheckDF]=NULL WHERE LENGTH([soCheckDF])=0;
UPDATE [HiveT] SET [soEndF]=NULL WHERE LENGTH([soEndF])=0;

the problem solved!
I still can't explain, why there was memory leak because of the (empty) values,
using FPSExport.
thank you wp, for your attention

ps
in the attachment there are 2 db, the old one and the corrected

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus