* * *

Author Topic: CEF3 issue [solved]  (Read 297 times)

aducom

  • Jr. Member
  • **
  • Posts: 61
    • http://www.aducom.com
CEF3 issue [solved]
« on: March 20, 2017, 03:09:11 pm »
I upgraded Lazarus to it's latest version. On the Lazarus wiki I read that there was a newer cef3 supported. I updated my component, downloaded the correct files (tried twice) and compiled.

I got an error on the property 'TabOrder' which didn't exists in the cef3 package. I looked into the code and the line is commented out. I removed this and recompiled. Now I get the message that the cef3 package is a unsupported version.

The cef versions on the wiki and github differ. I tried both, but none of them work. The wiki version is  CEF 3.2743, but there are 6 different subversions. Perhaps I choose the wrong one?

I tried to follow the sample from the website but if I try that I get an AV. In my original application I get a version error (uses a subproces like the simple sample application).

I'm not sure where to go from here. I don't mind spending some time into it, but I don't know where to look and what the problem might be. Does anybody have clues for this?

tnx, Albert

With big thanks to the maintainer this issue can be closed. Need to do a full clean install to get it going. Appearantly some old stuff is preventing the right working.
« Last Edit: March 20, 2017, 08:09:19 pm by aducom »

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus