* * *

Author Topic: [SOLVED] Prevent comment with form name from reappearing  (Read 692 times)

Eugene Loza

  • Sr. Member
  • ****
  • Posts: 449
    • My "almost daily" development blog
[SOLVED] Prevent comment with form name from reappearing
« on: March 09, 2017, 08:27:04 am »
Hi all!
I'm used to keep my code "condensed" without excessive linebreaks and useless comments. However, when I work with TForm I always get a { TFormName } comment popping up after adding elements to the form:
Code: Pascal  [Select]
  1. type
  2.  
  3.   { TDungeonTilesEditor }
  4.  
  5.   TDungeonTilesEditor = class(TForm)
I couldn't find the option to turn it off. And if I delete it, it reappears at the next element/event insertion in ObjectInspector.
« Last Edit: March 09, 2017, 10:20:43 am by Eugene Loza »
My Free and Open Source games in Lazarus/FreePascal/CastleGameEngine:
https://decoherence.itch.io/
(and some ancient games in Turbo Pascal too)
Sources are here: https://github.com/eugeneloza?tab=repositories

Ondrej Pokorny

  • Full Member
  • ***
  • Posts: 180
Re: Prevent comment with form name from reappearing
« Reply #1 on: March 09, 2017, 09:06:28 am »
Uncheck IDE Options -> Codetools -> Class Completion -> Header comment for class. If it doesn't help, report bug to mantis.

Eugene Loza

  • Sr. Member
  • ****
  • Posts: 449
    • My "almost daily" development blog
Re: Prevent comment with form name from reappearing
« Reply #2 on: March 09, 2017, 10:20:31 am »
Thanks a lot! That was exactly what I was looking for... Not sure how I missed it (I've looked at that page several times, but missed such an obvious option)...
My Free and Open Source games in Lazarus/FreePascal/CastleGameEngine:
https://decoherence.itch.io/
(and some ancient games in Turbo Pascal too)
Sources are here: https://github.com/eugeneloza?tab=repositories

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus