* * *

Author Topic: Lazarus 1.6.4 - Released  (Read 39394 times)

JD

  • Hero Member
  • *****
  • Posts: 1573
Re: Lazarus 1.6.4 - Released
« Reply #90 on: May 11, 2017, 12:05:11 pm »
I believe your code works with 1.8 as is. The IDE is improved, too. I dare to say it is safe to switch! Just try yourself.

Hi there Juha,

That sounds tempting. What changes have been made to the IDE for 1.8?

Thanks,

JD
Windows (10, 7) - Lazarus 1.6.4/FPC 3.0.2 (also Delphi occasionally)
Linux Mint Cinnamon  - Lazarus 1.4/FPC 2.6.4
Indy 10.6 series; Zeos 7.2.1; SQLite, Firebird, PostgreSQL & MariaDB

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2960
  • I like bugs.
Re: Lazarus 1.6.4 - Released
« Reply #91 on: May 11, 2017, 12:50:24 pm »
That sounds tempting. What changes have been made to the IDE for 1.8?
At least there is the new menu designer and the online package manager by GetMem is included.
The package manager itself is fully functional but not fully integrated with the rest of Lazarus package system, so it is still work in progress.

There are plenty of smaller fixes. Uhhh, somebody should update this page:
 http://wiki.freepascal.org/New_IDE_features_since#v1.8

LCL has new widgetsets, QT5 and GTK3 (which is still under construction).

Everyone please test the fixes 1.8 branch and report bugs.

Ondrej Pokorny

  • Full Member
  • ***
  • Posts: 162
Re: Lazarus 1.6.4 - Released
« Reply #92 on: May 11, 2017, 06:51:30 pm »

rick2691

  • Sr. Member
  • ****
  • Posts: 333
Re: Lazarus 1.6.4 - Released
« Reply #93 on: June 05, 2017, 07:33:24 pm »
I recently tried to install Lazarus 1.6.4 (3.0.2) 64bit onto a Windows 10 64bit computer.

It installed well, but it would not run or compile any apps. An error message was that it could not find the IDE config file. Another was, Illegal parameter: -Twin32.

I wasn't able to determine what that had applied to.

I also saw nothing where I could manually direct it to the IDE config file (I had created a separate folder for its files, because I had also installed as an independent compiler). So I uninstalled, and reinstalled. It still gave the same errors.

I then tried to install Lazarus 1.6.4 (3.0.2) 32bit. It behaved well with all my apps, and they would run and compile. No errors.

The drawback is that they are 32bit, and for most of them, I have to set their compatibility modes. Mostly because they do ActiveX to interact with other programs.

Additionally, I was able to use Anchordocking with both installs, but I did have to re-enable the Coolbar, as others have said. It was a bit of trouble to figure out how to do so. The setting wasn't anywhere that I would expect.

Rick
Windows XP Pro, Laz vrs 1.4.4, FPC vrs 2.6.4, svn vrs 49931, i386-win32-win32/win64, form uses windows unit

cvb255

  • Newbie
  • Posts: 1
Re: Lazarus 1.6.4 - Released
« Reply #94 on: June 08, 2017, 06:32:59 am »
thanks to the best team ever  ;D  i saw many developers like me will be very happy if lazarus support midi forms

taazz

  • Hero Member
  • *****
  • Posts: 3948
Re: Lazarus 1.6.4 - Released
« Reply #95 on: June 08, 2017, 06:39:11 am »
thanks to the best team ever  ;D  i saw many developers like me will be very happy if lazarus support midi forms
midi forms? any link to explain the concept?
Good judgement is the result of experience … Experience is the result of bad judgement.

OS : Windows 7 64 bit
Laz: Lazarus 1.4.4 FPC 2.6.4 i386-win32-win32/win64

Ñuño_Martínez

  • Hero Member
  • *****
  • Posts: 625
    • Burdjia
Re: Lazarus 1.6.4 - Released
« Reply #96 on: June 08, 2017, 09:47:33 am »
I think he/she means MDI support.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus