* * *

Author Topic: Blank form, program hanging in debug  (Read 509 times)

hakelm

  • Jr. Member
  • **
  • Posts: 70
Blank form, program hanging in debug
« on: February 22, 2017, 12:08:23 pm »
I have the following little annoying problem:
When I start my application in the IDE-debugger a blank form is opened up and the program (debugger?) hangs and can only be stopped with ctrl-F2
If I however single step to
Application.Run;
in the project file and then press F9 everything seems to work.
What can I do?
H
Ps
I am using Lazarus 1.6+dfsg-1 on Ubuntu 16.04

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4219
    • wiki
Re: Blank form, program hanging in debug
« Reply #1 on: February 22, 2017, 06:06:47 pm »
Strange...

Does "Pause" work?

You can try (far fetched) http://wiki.lazarus.freepascal.org/GDB_Debugger_Tips#On_Windows_Open.2FSave.2FFile_or_System_Dialog_cause_gdb_to_crash

------------------
Which version of gdb?

anything above gdb 7.7 may have issues with stabs. (afaik default by fpc)

Setting is in Project options / debug
AND fore EACH package in the package options.

(or use "Additions and overrides)
Either way, try changing ALL debug info to dwarf (with sets) / (But not dwarf 3)

---------
If still no success, go to the bottom of the page I linked above, and provide a log file.

--
Btw always use F9 to start your app (or "Run" from the menu, or the run button).
Do not start your app with F7 or F8, only use those if the app is already running/paused.

hakelm

  • Jr. Member
  • **
  • Posts: 70
Re: Blank form, program hanging in debug
« Reply #2 on: February 22, 2017, 07:51:49 pm »
Thanks
Synaptic tells me I have GDB 7.11.1-0ubuntu1~16.04, which I assume Lazarus uses.
I tested the different choices for debugger info and it is only Dwarf3(beta) (-gw3) that seems to work but Pause does not work:

The file "../sysdeps/unix/syscall-template.S" was not found.
Do you want to locate it yourself?

There is no file syscall-template.S on my system. What can I do about that?
Pls note my system has worked flawlessly earlier but in order to get anchordockingdsgn to work having tried some different Lazaruses but now I have reverted to 1.6+dfsg-1.
H

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus