* * *

Author Topic: [Solved] Recompile IDE 1.6.2 with newer FPC version? Issue with lclextensions0.6  (Read 952 times)

Girlbrush

  • Jr. Member
  • **
  • Posts: 63
Lazarus 1.6.2 r53354 FPC 3.0.0 x86_64-win64-win32/win64
Windows 10 Professional x64

I wanted to try and use the stable version of FPC (3.0.2).
I downloaded it using FPCUp_Deluxe, then change fpc.cfg to reflect the directory name change, and the compiler options in Lazarus (compiler executable and FPC source directory).

But the IDE (1.6.2) can not be rebuilt with any other version then the one it came with (3.0.0). Error in oleutils.pas (see screenshot).

I don't know if I did something wrong or if it really is just incompatible.

[EDIT]oleutils is part of lclentensions used by VirtualTreeview.
« Last Edit: February 20, 2017, 11:13:35 am by Girlbrush »
Getting back into programming after 8+ years.

Cyrax

  • Sr. Member
  • ****
  • Posts: 481
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #1 on: February 14, 2017, 04:42:30 pm »
Please show more lines above line 110.

Thaddy

  • Hero Member
  • *****
  • Posts: 3031
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #2 on: February 14, 2017, 06:03:05 pm »
Line 110 has an issue but give us the declarations.
« Last Edit: February 14, 2017, 06:05:08 pm by Thaddy »

jacmoe

  • Full Member
  • ***
  • Posts: 240
    • Jacmoe's Cyber SoapBox
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #3 on: February 14, 2017, 06:05:45 pm »
What I seem to see is that the define that we can't see should have been defined so that QWord instead of Int64 was used..

However, check that the Lazarus ide build has been set correctly. Platform and OS - there seems to be some confusion about whether or not to enable 64 bit ??
« Last Edit: February 14, 2017, 06:07:22 pm by jacmoe »
more signal - less noise

Thaddy

  • Hero Member
  • *****
  • Posts: 3031
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #4 on: February 14, 2017, 06:10:46 pm »
What I seem to see is that the define that we can't see should have been defined so that QWord instead of Int64 was used..

However, check that the Lazarus ide build has been set correctly. Platform and OS - there seems to be some confusion about whether or not to enable 64 bit ??
oleutils is part of the distribution?..... Where?

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2761
  • I like bugs.
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #5 on: February 14, 2017, 06:40:37 pm »
Quote
I wanted to try and use the stable version of FPC (3.0.2)
Actually FPC 3.0.2 release version still does not exist. Maybe it happens this year, let's see...

jacmoe

  • Full Member
  • ***
  • Posts: 240
    • Jacmoe's Cyber SoapBox
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #6 on: February 14, 2017, 06:44:38 pm »
[oleutils is part of the distribution?..... Where?
I am seeing that the code expects QWord, but got an Int64. The conditional define seems to disagree.
In the lines before the break at 110.

Could be related to the edit of 'fpc.cfg' ..
more signal - less noise

zeljko

  • Hero Member
  • *****
  • Posts: 888
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #7 on: February 14, 2017, 07:16:26 pm »
oleutils is part of the distribution?..... Where?
As I can see he is trying to compile lclextensions_package, created to help porting of VirtualTrees (TVirtualStringTree) to lazarus.
oleutils is unit inside lclextensions sources (empty for non win23 widgetsets afair)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 634
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #8 on: February 14, 2017, 07:28:50 pm »
Here you go ... I think related:
http://bugs.freepascal.org/view.php?id=29641

Girlbrush

  • Jr. Member
  • **
  • Posts: 63
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #9 on: February 15, 2017, 07:39:42 am »
Thank you all for your replies!

I thought oleutils was part of the IDE, that's why I didn't include more of the code, or check myself more thoroughly.  :-[
I will try a more recent CCR.

@JuhaManninen: FPCUp calls it stable, it's tagged with 3.0.2
@zeljko and @DonAlfredo: Thanks for the tips ;)
Getting back into programming after 8+ years.

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2761
  • I like bugs.
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #10 on: February 15, 2017, 08:34:25 am »
@JuhaManninen: FPCUp calls it stable, it's tagged with 3.0.2
Yes, it is tagged but still not released for some reason.

Girlbrush

  • Jr. Member
  • **
  • Posts: 63
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #11 on: February 20, 2017, 10:30:24 am »
Apparently lclextension-0.6 that is available from the VirtualTreeView releases page is the latest version of the package. The one in CCR is 0.5.1 and does not fulfill the dependency of Virtualtreeview. Not sure what to do.

I have edited fpc.cfg to correct the paths only.
Getting back into programming after 8+ years.

zeljko

  • Hero Member
  • *****
  • Posts: 888
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Recompile IDE 1.6.2 with newer FPC version?
« Reply #12 on: February 20, 2017, 10:53:01 am »
Just change Int64 cast to QWord and it'll work (tried yesterday), trunk lazarus works fine with 3.0.2

Girlbrush

  • Jr. Member
  • **
  • Posts: 63
Here's how I "solved" this problem, lclextensions will then compile with FPC3.0.0 and 3.0.2:

change the version conditional to
Code: Pascal  [Select]
  1. {$if FPC_FULLVERSION >= 30001}
Getting back into programming after 8+ years.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus