* * *

Author Topic: After upgrade to fpc, Lazarus 1.6.2 stops working.  (Read 4579 times)

lab51

  • New member
  • *
  • Posts: 15
After upgrade to fpc, Lazarus 1.6.2 stops working.
« on: February 11, 2017, 06:30:46 pm »
I have a clean installation of Linux Mint KDE 18.1 (Serena). I downloaded the installation files from lazarus-ide.org, namely:
fpc_3.0.0-151205_amd64.deb,
fpc-src_3.0.0-151205_amd64, and
lazarus-project_1.6.2-1_amd64.

Lazarus works fine after I install these files.  Linux wants to upgrade fpc to fpc-3.0.0+dfsg-2.  If I do this Lazarus will no longer compile, giving me an error that Forms is not found, as well as Implementation is not found.

I've tried various differences on a fresh OS installation, installing fpc-3.0.0+dfsg-2 first, installing fpc and lazarus from the synaptics package manager, etc. The only way that Lazarus will work is installing the 3 files shown above.  However, now I'm nagged to update.

Any thoughts?  I'd like to be able to have everything updated, and if I should ever do a supo apt-get update then I'll destroy Lazarus.

john


jacmoe

  • Sr. Member
  • ****
  • Posts: 255
    • Jacmoe's Cyber SoapBox
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #1 on: February 11, 2017, 06:35:37 pm »
If you select to ignore the updates for Lazarus / FPC then you will not get bugged about the updates any more.
Just right-click in the update manager and choose 'Ignore'.

It seems to be a misconfiguration in the official Lazarus / FreePascal packages causing the package manager to think they need to be updated to older versions..

However, I have found that using Fpcupdeluxe to install Lazarus / FreePascal locally (in your home directory) actually is both smoother and less error prone than having a global installation.

If you choose to use Fpcupdeluxe, then if you download and run it, clicking the 'Fixes' button will install Lazarus 1.6.3+ (with FPC 3.0.0 IIRC).
« Last Edit: February 11, 2017, 06:43:25 pm by jacmoe »
more signal - less noise

Handoko

  • Hero Member
  • *****
  • Posts: 1400
  • My goal: build my own game engine using Lazarus
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #2 on: February 11, 2017, 06:52:27 pm »
Any thoughts?  I'd like to be able to have everything updated, and if I should ever do a supo apt-get update then I'll destroy Lazarus.

I don't know much about Linux Mint. But as far as I know, Ubuntu repository for Lazarus & FPC is not up to date. So the update usually is a downgrade.

If visit this forum frequently, you will know when a new version of Lazarus/FPC is released. To upgrade my own, I simple download from Lazarus official (SourceForge), uninstall the old and install the 3 newly downloaded packages.

If you use Synaptic Package Manager, you can disable the (false) upgrade notification by locking the version:
Choose the item to lock > Synaptic main menu > Package > Lock Version
« Last Edit: February 11, 2017, 06:58:21 pm by Handoko »

lab51

  • New member
  • *
  • Posts: 15
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #3 on: February 11, 2017, 07:23:19 pm »
Thank you. I'll try the lock.

lab51

  • New member
  • *
  • Posts: 15
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #4 on: February 11, 2017, 07:24:27 pm »
However, I have found that using Fpcupdeluxe to install Lazarus / FreePascal locally (in your home directory) actually is both smoother and less error prone than having a global installation.

If you choose to use Fpcupdeluxe, then if you download and run it, clicking the 'Fixes' button will install Lazarus 1.6.3+ (with FPC 3.0.0 IIRC).

Thanks. I'll google the fpcupdeluxe and see if I can find it.

jacmoe

  • Sr. Member
  • ****
  • Posts: 255
    • Jacmoe's Cyber SoapBox
more signal - less noise

BBasile

  • Sr. Member
  • ****
  • Posts: 291
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #6 on: February 11, 2017, 11:45:15 pm »
I have a clean installation of Linux Mint KDE 18.1 (Serena). I downloaded the installation files from lazarus-ide.org, namely:
fpc_3.0.0-151205_amd64.deb,
fpc-src_3.0.0-151205_amd64, and
lazarus-project_1.6.2-1_amd64.

Lazarus works fine after I install these files.  Linux wants to upgrade fpc to fpc-3.0.0+dfsg-2.  If I do this Lazarus will no longer compile, giving me an error that Forms is not found, as well as Implementation is not found.

I've tried various differences on a fresh OS installation, installing fpc-3.0.0+dfsg-2 first, installing fpc and lazarus from the synaptics package manager, etc. The only way that Lazarus will work is installing the 3 files shown above.  However, now I'm nagged to update.

Any thoughts?  I'd like to be able to have everything updated, and if I should ever do a supo apt-get update then I'll destroy Lazarus.

john

Damn, I have the same issue under Mint 17.1, Lazarus 1.6.2 and the failure started after installing FPC 3.0.2-rc1 manually.
I've managed to compile the IDE and my stuff (2 release since) but each time I have to recompile by hand namely
- the FCL
- the LCL
(you can do this quiclkly in the project inspector: click package and recompile in the package visual form).
and then suddenly my project can be compiled again. This is extremely annoying. My OpenSuse and Win32 setup don't have this issue.

jacmoe

  • Sr. Member
  • ****
  • Posts: 255
    • Jacmoe's Cyber SoapBox
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #7 on: February 11, 2017, 11:47:55 pm »
This is probably related to permission issues since Lazarus / FPC are installed globally.
Use fpcupdeluxe which installs into your home directory.
Then you will be able to recompile/install as much as you wish.

Otherwise, you must become root. Which I'd recommend against.
more signal - less noise

lab51

  • New member
  • *
  • Posts: 15
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #8 on: February 15, 2017, 05:11:57 pm »
I downloaded the utility (fpcupdeluxe-x86_64-linux) but it won't run. The error log is below.
(Incidentally after telling the update to ignore fpc updates lazarus has completely disappeared from my system.)


Going to install/update FPC and Lazarus with given options.
FPCUP(deluxe) is starting up.

Bootstrap dir:      /home/sparky/fpcupdeluxe/fpcbootstrap
FPC URL:               http://svn.freepascal.org/svn/fpc/tags/release_3_0_2
FPC options:           
FPC source directory:  /home/sparky/fpcupdeluxe/fpcsrc
FPC install directory: /home/sparky/fpcupdeluxe/fpc
Lazarus URL:        http://svn.freepascal.org/svn/lazarus/tags/lazarus_1_6_2
Lazarus options:   
Lazarus directory:  /home/sparky/fpcupdeluxe/lazarus
Please stand back and enjoy !

fpcupdeluxe: info: 15-2-17 11:09:57: fpcup019 (20170209) started.
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libX11.so
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libgdk_pixbuf-2.0.so
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libpango-1.0.so
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libgdk-x11-2.0.so
fpcupdeluxe: ERROR: You need to install at least libX11-dev libgtk2.0-dev libcairo2-dev libpango1.0-dev libxtst-dev libgdk-pixbuf2.0-dev libatk1.0-dev libghc-x11-dev to build Lazarus !!
fpcupdeluxe: ERROR: Make, binutils, subversion/svn [and gdb] are also required !!
Executing : as "--version" (working dir: )
GNU assembler (GNU Binutils for Ubuntu) 2.26.1
Copyright (C) 2015 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `x86_64-linux-gnu'.
Executing : unzip "-v" (working dir: )
UnZip 6.00 of 20 April 2009, by Debian. Original by Info-ZIP.

Latest sources and executables are at ftp://ftp.info-zip.org/pub/infozip/ ;
see ftp://ftp.info-zip.org/pub/infozip/UnZip.html for other sites.

Compiled with gcc 5.2.1 20151119 for Unix (Linux ELF).

UnZip special compilation options:
        ACORN_FTYPE_NFS
        COPYRIGHT_CLEAN (PKZIP 0.9x unreducing method not supported)
        SET_DIR_ATTRIB
        SYMLINKS (symbolic links supported, if RTL and file system permit)
        TIMESTAMP
        UNIXBACKUP
        USE_EF_UT_TIME
        USE_UNSHRINK (PKZIP/Zip 1.x unshrinking method supported)
        USE_DEFLATE64 (PKZIP 4.x Deflate64(tm) supported)
        UNICODE_SUPPORT [wide-chars, char coding: UTF-8] (handle UTF-8 paths)
        LARGE_FILE_SUPPORT (large files over 2 GiB supported)
        ZIP64_SUPPORT (archives using Zip64 for large files supported)
        USE_BZIP2 (PKZIP 4.6+, using bzip2 lib version 1.0.6, 6-Sept-2010)
        VMS_TEXT_CONV
        WILD_STOP_AT_DIR
        [decryption, version 2.11 of 05 Jan 2007]

UnZip and ZipInfo environment options:
           UNZIP:  [none]
        UNZIPOPT:  [none]
         ZIPINFO:  [none]
      ZIPINFOOPT:  [none]
fpcupdeluxe: ERROR: Could not find SVN executable. Please make sure it is installed.
fpcupdeluxe: info: Error running fpcup. Technical details: error executing sequence fpc; line: 2, param: FPC
fpcupdeluxe: info: Error running fpcup. Technical details: error executing sequence Default; line: 3, param: fpc


ERROR: Fpcupdeluxe failed.
[WARNING] Invalid borders specified for theme pixmap:
        /usr/share/themes/Breeze/gtk-2.0/../assets/line-h.png,
borders don't fit within the image

jacmoe

  • Sr. Member
  • ****
  • Posts: 255
    • Jacmoe's Cyber SoapBox
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #9 on: February 15, 2017, 05:23:51 pm »
Code: Pascal  [Select]
  1. sudo apt-get install libx11-dev libgtk2.0-dev libcairo2-dev libpango1.0-dev libxtst-dev libgdk-pixbuf2.0-dev libatk1.0-dev libghc-x11-dev

It literally told you that, the error messages you got.  :)
« Last Edit: February 15, 2017, 07:07:52 pm by jacmoe »
more signal - less noise

jacmoe

  • Sr. Member
  • ****
  • Posts: 255
    • Jacmoe's Cyber SoapBox
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #10 on: February 15, 2017, 05:25:23 pm »
Also:
Code: Pascal  [Select]
  1. sudo apt-get install build-essential subversion

And, possibly also 'binutils'.
« Last Edit: February 15, 2017, 07:07:59 pm by jacmoe »
more signal - less noise

Thaddy

  • Hero Member
  • *****
  • Posts: 4212
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #11 on: February 15, 2017, 05:27:07 pm »
This is probably related to permission issues since Lazarus / FPC are installed globally.
No it isn't.
FPC is installed for the current user: /usr/local/bin and /usr/local/lib/fpc/x.x.x/
Afaik the same on Windows.

If you use an alternative means of install like fpcup that can not be guaranteed, however.

The rest of your information was correct: the dependencies.
« Last Edit: February 15, 2017, 05:29:30 pm by Thaddy »
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

lab51

  • New member
  • *
  • Posts: 15
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #12 on: February 15, 2017, 05:28:41 pm »
Code: Pascal  [Select]
  1. sudo apt-get install libX11-dev libgtk2.0-dev libcairo2-dev libpango1.0-dev libxtst-dev libgdk-pixbuf2.0-dev libatk1.0-dev libghc-x11-dev

It literally told you that, the error messages you got.  :)

I'm sorry, I don't see where you said that.

jacmoe

  • Sr. Member
  • ****
  • Posts: 255
    • Jacmoe's Cyber SoapBox
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #13 on: February 15, 2017, 05:31:07 pm »
FPC is installed for the current user: /usr/local/bin and /usr/local/lib/fpc/x.x.x/
Afaik the same on Windows.

/usr/local does not mean 'current user'.

Good luck doing anything in /usr/local without root privileges.

Current user only has full control over files in /home/[user_name]

If you use an alternative means of install like fpcup that can not be guaranteed, however.
It is only a small wrapper on top of the standard Lazarus/FPC build, so it is quite close to being official.

In my opinion / experience, using fpcupdeluxe to build Lazarus/FPC yourself, locally (in your home directory), is far less error prone than installing Lazarus globally.
« Last Edit: February 15, 2017, 05:37:15 pm by jacmoe »
more signal - less noise

jacmoe

  • Sr. Member
  • ****
  • Posts: 255
    • Jacmoe's Cyber SoapBox
Re: After upgrade to fpc, Lazarus 1.6.2 stops working.
« Reply #14 on: February 15, 2017, 05:32:31 pm »
I'm sorry, I don't see where you said that.

I said 'it', not 'I' - see the output that you posted earlier:

Quote
fpcupdeluxe: info: 15-2-17 11:09:57: fpcup019 (20170209) started.
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libX11.so
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libgdk_pixbuf-2.0.so
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libpango-1.0.so
fpcupdeluxe: ERROR: Required package is not installed for Lazarus: libgdk-x11-2.0.so
fpcupdeluxe: ERROR: You need to install at least libX11-dev libgtk2.0-dev libcairo2-dev libpango1.0-dev libxtst-dev libgdk-pixbuf2.0-dev libatk1.0-dev libghc-x11-dev to build Lazarus !!
fpcupdeluxe: ERROR: Make, binutils, subversion/svn [and gdb] are also required !!
more signal - less noise

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus