* * *

Author Topic: [Solved] Cannot find installed controls  (Read 437 times)

jacmoe

  • Full Member
  • ***
  • Posts: 242
    • Jacmoe's Cyber SoapBox
[Solved] Cannot find installed controls
« on: February 07, 2017, 09:18:40 pm »
Lazarus works great, as long as I do not try and install additional packages.

I installed the lazopenglcontext and the Castle engine controls, and Lazarus cannot find it, even after it successfully compiled.  :-X

It is installed, both design and runtime.
I don't remember any 'compile-time' installation options from my Delphi days, .. so what am I supposed to do?

This is using Lazarus (1.6.3) from fpcupdeluxe.

Note: the same thing happens when using just the OpenGLContext control - it can't find that either..
« Last Edit: February 07, 2017, 10:56:08 pm by jacmoe »
more signal - less noise

jacmoe

  • Full Member
  • ***
  • Posts: 242
    • Jacmoe's Cyber SoapBox
Re: Cannot find installed controls
« Reply #1 on: February 07, 2017, 10:54:11 pm »
I figured it out! :D

The problem was that Lazarus couldn't figure out what my platform was, and therefore the build settings didn't have Target OS and Target CPU set.

That meant that, although everything compiled OK, it failed to run because it couldn't find the runtime components..

The fix was to enter Tools -> Configure "build Lazarus" and fill out the blanks.

« Last Edit: February 07, 2017, 10:57:21 pm by jacmoe »
more signal - less noise

jacmoe

  • Full Member
  • ***
  • Posts: 242
    • Jacmoe's Cyber SoapBox
Re: [Solved] Cannot find installed controls
« Reply #2 on: February 07, 2017, 11:04:21 pm »
Since this seems to be related to the fact that I am using a non-standard Linux distribution (Netrunner) this topic could probably be moved to the Linux forum, perhaps?
more signal - less noise

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus