* * *

Author Topic: [SOLVED] Can't install BGRAControls or any package that uses BGRABitmap  (Read 877 times)

lainz

  • Hero Member
  • *****
  • Posts: 2001
Hi, today I've downloaded fpcupdeluxe and installed fpc trunk and lazarus trunk for Windows i386. Then I installed bgrabitmap and bglcontrols. But when I try to install BGRAControls or any package that uses BGRABitmap I get this error message:

Warning: Recompiling BCButton, checksum changed for BGRABitmap
bcbutton.pas(78,12) Fatal: Can't find unit BCButton used by bgracontrols

I have the same package installed in fpc 3.0 laz 1.6 and is everything working fine.

Another:

Warning: Recompiling BGRALayers, checksum changed for BGRABitmapTypes
viewunit.pas(11,44) Fatal: Cannot find BGRALayers used by ViewUnit, incompatible ppu=C:\Users\*****\Documents\GitHub\bgrabitmap\bgrabitmap\lib\i386-win32\3.1.1\bgralayers.ppu, multiple packages: BGLControls, BGRABitmapPack
« Last Edit: January 31, 2017, 01:52:53 pm by lainz »

lainz

  • Hero Member
  • *****
  • Posts: 2001
Re: Can't install BGRAControls or any package that uses BGRABitmap
« Reply #1 on: January 31, 2017, 01:52:41 pm »
Solved. I needed to compile first Lazarus 'Optimized IDE' in order to work. All other modes including the clean and build all didn't work.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus