* * *

Author Topic: Gdb issue with siearra and 1.6.2  (Read 1209 times)

tolisoft

  • Newbie
  • Posts: 4
Gdb issue with siearra and 1.6.2
« on: December 02, 2016, 09:45:03 am »
Hello,
I tried to install lazarus 1.6.2 in macos Sierra. I used the official pakages from sf.net. When I tried to compile something the compilation proccess works file but when the new binary is started I get the following error for the debugger: (see the picture)

How can I fix this?


Thaddy

  • Hero Member
  • *****
  • Posts: 4752
Re: Gdb issue with siearra and 1.6.2
« Reply #1 on: December 02, 2016, 09:53:33 am »
That's a very well known issue with GDB under Sierra.
It has been answered many times on this forum, but the issue is a GDB issue.

Use the search in the left column ("GDB Sierra"), but this is a good pointer: http://forum.lazarus.freepascal.org/index.php/topic,34618.msg227227.html#msg227227
« Last Edit: December 02, 2016, 09:56:51 am by Thaddy »
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

jwdietrich

  • Hero Member
  • *****
  • Posts: 936
    • formatio reticularis
Re: Gdb issue with siearra and 1.6.2
« Reply #2 on: January 07, 2017, 08:36:03 pm »
You might also want to read the Mac Installation FAQ.
function GetRandomNumber: integer; // xkcd.com
begin
  GetRandomNumber := 4; // chosen by fair dice roll. Guaranteed to be random.
end;

Lazarus 1.6.4 | FPC 3.0.2 | PPC, Intel, ARM | macOS, Windows, Linux

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus