* * *

Author Topic: How to force Lazarus to use Cocoa widget set?  (Read 850 times)

xaver13

  • Jr. Member
  • **
  • Posts: 78
How to force Lazarus to use Cocoa widget set?
« on: November 18, 2016, 04:33:45 pm »
Hello, please is there any possibility to force Lazarus to use Cocoa Widgetset?
In project properties is widgets  carbon and it is impossible to change it.

Trying to add cocoa package results in: appkit unit is twice in IDE units path
lcl/interfaces/carbon/pascocoa/lib/i386-darwin/appkit.ppu
lcl/units/i386-darwin/appkit.ppu



Thank you for reply.
--
Jiri Cvrk

Phil

  • Hero Member
  • *****
  • Posts: 2316
Re: How to force Lazarus to use Cocoa widget set?
« Reply #1 on: November 18, 2016, 04:48:14 pm »
1. You'll need to use Lazarus trunk. The cocoa widgetset code in 1.6.2 is about a year old.

2. You'll need to compile the cocoa widgetset. Tools | Configure.

3. Switch your project's widgetset from carbon (default) to cocoa in Config and Target options.

3a. Alternatively, compile project with lazbuild if you want to leave its widgetset set to carbon.

lazbuild projectname.lpi --widgetset=cocoa

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus