* * *

Author Topic: mysql connector 5.6  (Read 4151 times)

xaver13

  • Jr. Member
  • **
  • Posts: 78
mysql connector 5.6
« on: November 14, 2016, 03:08:16 pm »
Hello, using lazarus I need mysql/c connector libmysqlclient.dylib or libmysqlclient.18.dylib for Tmysql56Connection,  I need 32 bit version.

On dev.mysql.com is only 6.0.2 available  as oldest version to download, it has  libmysqlclient.18.dylib name, but is version 6.1.6 lazarus message is: expected 5.6 got 6.1.6.

Please anybody knows where to download 5.6   libmysqlclient.dylib   32 bit versions? I searched web more times without success. Thanks you very much for help.
--
Jiri Cvrk

Thaddy

  • Hero Member
  • *****
  • Posts: 4635
Re: mysql connector 5.6
« Reply #1 on: November 14, 2016, 03:19:40 pm »
You didn't look, did you?
Look at this page:
http://dev.mysql.com/downloads/mysql/ and look to the right and previous versions.

BTW: current is 5.7, not 6.0, that is yet to be released. The client lib is included.

And 32 bit what? ARM?
« Last Edit: November 14, 2016, 03:26:52 pm by Thaddy »
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

xaver13

  • Jr. Member
  • **
  • Posts: 78
Re: mysql connector 5.6
« Reply #2 on: November 14, 2016, 03:53:40 pm »
You didn't look, did you?
Look at this page:
http://dev.mysql.com/downloads/mysql/ and look to the right and previous versions.

BTW: current is 5.7, not 6.0, that is yet to be released. The client lib is included.

And 32 bit what? ARM?

Thank you, Thaddy, your link seems to be to server, server for mac and the appropriate libmysqlclient.dylib there is 64bit. I tried this.. (but ..  I am a beginner  ;)   )

I think I need 32 bit version because I have 32 bit Lazarus and even I tried to switch to 64 bit app output, it is not working - message: can not load libmysqlclient.dylib. In that lazarus I have only Tmysql56Connection, nothing newer available. I am a beginner with Lazarus, and ... I tried to find solution whole weekend but without success.  Therefore I started to look for 32 bit dynamic library. And on the same page you mean above is link to connector. And there is 32bit connector for mac. But 6.0.2 is the oldest one there, named (mysql-connector-c-6.0.2-osx10.5-x86-32bit.tar.gz)  link: http://dev.mysql.com/downloads/connector/c/

Or is there any better way for beginner? I have mySQL application working on Windows and I wanted to try it on Mac. Thank you very much for help.
--
Jiri Cvrk

xaver13

  • Jr. Member
  • **
  • Posts: 78
was: mysql connector 5.6 - what about to compile to 64 bit?
« Reply #3 on: November 15, 2016, 09:15:35 pm »
o.k. I can not found 32 bit libmysqlclient.dylib.  version 5.6 anywhere and no one helped.

I checked in Lazarus project target to x86_64 and received a message that target is not supported.

Lazarus is distributed  in 32bit version for  64bit OS and is compiling 32bit application by default.  And the way to compile 64 bit app is not simple, especially for beginner.
I found a page http://wiki.lazarus.freepascal.org/Cross_compiling#From_Darwin_i386_to_x86_64 and seems that I need to compile fps
$ cd fpc
$ make all CPU_TARGET=x86_64

BUT: it fails in Sierra "fpc No rule to make target `all'.  Stop."       Make on Sierra is 3.81 version. I tried newer but, result seems  to be the same.

And that is the end for me as beginner, I am totally lost.

Can I trust to Lazarus documentation pages? Nothing is working.
--
Jiri Cvrk

Thaddy

  • Hero Member
  • *****
  • Posts: 4635
Re: mysql connector 5.6
« Reply #4 on: November 15, 2016, 09:21:35 pm »
Ok. If Lacak reads this he can solve it in seconds but otherwise I look into it tomorrow. ok?
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

xaver13

  • Jr. Member
  • **
  • Posts: 78
Re: mysql connector 5.6
« Reply #5 on: November 17, 2016, 10:50:00 am »
still not solved.

Still 'ElnOutError', TMySQL56Connection can not work wit installed MySQL client version: Expected(5.6), got (6.1.6)

What I can not understand, that Windows libmysql.dll version is 5.6.33 , Mac OS libmysqlclient.dylib is 6.1.6 and I can not find 5.6 even in oldest archives here https://downloads.mysql.com/archives/c-c/  (oldest is 6.0 from Apr 1, 2009 !!!!).
And the newest component TMySQL56Connection in Lazarus is 5.6. 

It is crazy. What do I wrong?   Am I the only one person trying to work with MySQL on the world?  :o   Thank you for any reply.
« Last Edit: November 17, 2016, 10:51:40 am by xaver13 »
--
Jiri Cvrk

Thaddy

  • Hero Member
  • *****
  • Posts: 4635
Re: mysql connector 5.6
« Reply #6 on: November 17, 2016, 11:51:00 am »
I have no clue. The official Oracle MySql website states the current release is 5.7 not 6.1.
On my MAC mini I have no problems at all.

Also note that the server includes the client.
I have no clue what you are doing, because i can't even find a proper 6.1 release from either the Oracle website or the Mysql community edition.
With MySQL the client NEEDS to match the server. Same version.

And the newest component in FPC (not Lazarus) is 5.7.
« Last Edit: November 17, 2016, 11:56:19 am by Thaddy »
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

josh

  • Sr. Member
  • ****
  • Posts: 434
Re: mysql connector 5.6
« Reply #7 on: November 17, 2016, 12:13:36 pm »
Hi

Not sure if this link may help or not; but you can choose which version to download.

http://mac.filehorse.com/download-mysql/4774/

Not sure if you will need to symlink to the dylib to get it to work, as El_Capitan and above have SIP which could interfere with direct access to the library. Unless you temporarily disabled SIP when you installed mysql and re enabled after.
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5818
Re: mysql connector 5.6
« Reply #8 on: November 17, 2016, 12:57:13 pm »
If I look on the site that Thaddy posted, I see a website with a "dev" tab with 6.x, and a "general availability" tab, with 5.5 - 5.7

xaver13

  • Jr. Member
  • **
  • Posts: 78
Re: mysql connector 5.6
« Reply #9 on: November 17, 2016, 01:51:04 pm »
Hi

Not sure if this link may help or not; but you can choose which version to download.

http://mac.filehorse.com/download-mysql/4774/

Not sure if you will need to symlink to the dylib to get it to work, as El_Capitan and above have SIP which could interfere with direct access to the library. Unless you temporarily disabled SIP when you installed mysql and re enabled after.

Thank you very much , Josh, it helped!  :D
--
Jiri Cvrk

Thaddy

  • Hero Member
  • *****
  • Posts: 4635
Re: mysql connector 5.6
« Reply #10 on: November 17, 2016, 02:44:34 pm »
Hi

Not sure if this link may help or not; but you can choose which version to download.

http://mac.filehorse.com/download-mysql/4774/

Not sure if you will need to symlink to the dylib to get it to work, as El_Capitan and above have SIP which could interfere with direct access to the library. Unless you temporarily disabled SIP when you installed mysql and re enabled after.

You should NOT encourage people to download software binaries from an unofficial source.
As I stated and Marco verified: the OFFICIAL source has 5.7 as the highest official release.
One should use that. And FPC supports it.
You can also use the development version from the OFFICIAL source, we call that trunk. In that case build from sources and adapt the FPC version accordingly ;)
Officially there are no supported distributions 6.X. Be warned.
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

dogriz

  • Jr. Member
  • **
  • Posts: 86
    • Tech blog - Delphi, Lazarus, Firebird, Windows, Linux, Android...
Re: mysql connector 5.6
« Reply #11 on: November 21, 2016, 04:11:45 pm »
Am I right that there is no design time MySQL57Connection component in Lazarus, just as there is no TSQLConnector.ConnectorType for MySQL 5.7? (in 1.6.2 release, fixes and trunk versions - just the same)
Is it posible to add it? I would, but don't know how  :(
FPC 3.0.3
Lazarus 1.6.5
Debian x86_64, arm

Thaddy

  • Hero Member
  • *****
  • Posts: 4635
Re: mysql connector 5.6
« Reply #12 on: November 21, 2016, 04:37:36 pm »
5.7 is in trunk.
It does not rely on specific compiler features, so you can simply use the unit.
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

dogriz

  • Jr. Member
  • **
  • Posts: 86
    • Tech blog - Delphi, Lazarus, Firebird, Windows, Linux, Android...
Re: mysql connector 5.6
« Reply #13 on: November 21, 2016, 05:29:15 pm »
5.7 is in trunk.
It does not rely on specific compiler features, so you can simply use the unit.
I do use the unit, but sometimes, doing it through GUI with design time components is more convenient for rapid application development.
FPC 3.0.3
Lazarus 1.6.5
Debian x86_64, arm

Thaddy

  • Hero Member
  • *****
  • Posts: 4635
Re: mysql connector 5.6
« Reply #14 on: November 21, 2016, 05:47:32 pm »
It is also a component in Lazarus trunk.
"Logically, no number of positive outcomes at the level of experimental testing can confirm a scientific theory, but a single counterexample is logically decisive."

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus