* * *

Author Topic: Fpcupdeluxe  (Read 87427 times)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Fpcupdeluxe
« on: November 01, 2016, 03:13:59 pm »
Introducing fpcupdeluxe. A GUI tool that is based on fpcup by the late Renier.

https://github.com/LongDirtyAnimAlf/Reiniero-fpcup/releases/tag/0.91

Still pre-mature, but ready to use in most cases.

It will ease the install of FPC and Lazarus.
And, as with fpcup, it is fully self-contained, meaning that you can install it on your system without worries about other installs of FPC and Lazarus.
BUT USE THE LINK THAT WILL BE CREATED BY FPCUPDELUXE TO START LAZARUS !

Use the quick-start buttons to install a standard flavor of FPC and Lazarus.
After install, you can add packages from the module list.

And also, you can install cross-compilers for various system.
For Windows, libraries and bintools will be downloaded automagically (when available).

When crossing for Android, it will first search the standard locations for the NDK and SDK.
In case of failure, it will download  the right tools.

Pre-release. Have fun and give feedback !
« Last Edit: November 01, 2016, 04:55:24 pm by DonAlfredo »

lainz

  • Hero Member
  • *****
  • Posts: 2001
Re: Fpcupdeluxe
« Reply #1 on: November 01, 2016, 03:24:11 pm »
Hi, I've downloaded the version for x86_64. I've selected trunk both for fpc and lazarus and installed it. Lazarus 1.7 64 bits.

When I want to install a cross compiler for i386 it gives me some errors:
Code: Pascal  [Select]
  1. fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time
  2. fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time
  3. fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time
  4. fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time
  5. constexp.pas(87,1) Fatal: There were 4 errors compiling module, stopping
  6. Fatal: Compilation aborted

If I want to install cross compiler how I can do? I need to compile first for fpc i386 and then cross compile for x86_64? How?

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Re: Fpcupdeluxe
« Reply #2 on: November 01, 2016, 03:36:00 pm »
@lainz
Windows ? Linux ?
On Windows:
Recommended: install 32bit, cross towards 64bit.
The cross-compiler will already be installed by fpcupdeluxe.
GDB versions for 32bit and 64bit will also be available and will switch over automagically.

lainz

  • Hero Member
  • *****
  • Posts: 2001
Re: Fpcupdeluxe
« Reply #3 on: November 01, 2016, 03:38:57 pm »
Windows.
Quote
Recommended: install 32bit, cross towards 64bit.
Ok as supposed, I will try again.

Edit: Done. Better that installing all by hand.
« Last Edit: November 01, 2016, 04:21:28 pm by lainz »

MementoMojito

  • Jr. Member
  • **
  • Posts: 57
Re: Fpcupdeluxe
« Reply #4 on: November 01, 2016, 04:36:46 pm »
Hi DonAlfredo,

Thanks for this great tool : )
I have never used fpcup before but I thought I would it give it a go. I am on Debian Jessie x86-64 and I am trying to install FPC stable and Laz stable for x86_64.
However I have the error:

Code: Pascal  [Select]
  1. fpclazup: ERROR: Could not find SVN executable. Please make sure it is installed.
  2. fpclazup: info: Error running fpcup. Technical details: error executing sequence fpc; line: 2, param: FPC
  3. fpclazup: info: Error running fpcup. Technical details: error executing sequence Default; line: 3, param: fpc
  4.  

So quite obviously I need SVN; I have installed kdesvn but still no joy. What package is missing if you ever know?

Thanks!

xaver13

  • Jr. Member
  • **
  • Posts: 63
Re: Fpcupdeluxe
« Reply #5 on: November 01, 2016, 04:42:10 pm »
Hello, I installed 32 bit  Fpcupdeluxe (on Windows 10 64 bit) and then 1.7 +3.1.1 . I have 4K resolution, Lazarus IDE was to small. I needed to recompile IDE once again with dpi awareness switched of. The only way I know to do it was to open IDE project in Lazarus, set dpi awareness to off and then to rebuild IDE from Lazarus without using Fpcupdeluxe.

O.K. but I could not build Lazarus IDE in 64 bit because of wrong version fpc.
And ..  my own application I can build in both 32 and 64 bit versions...

Should I try anything else?
« Last Edit: November 01, 2016, 04:53:13 pm by xaver13 »
--
Jiri Cvrk

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Re: Fpcupdeluxe
« Reply #6 on: November 01, 2016, 04:49:57 pm »
@MementoMojito
sudo apt-get install subversion

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Re: Fpcupdeluxe
« Reply #7 on: November 01, 2016, 04:53:38 pm »
@xaver13
If I understand you correctly, you want both win32 bit and win64.
If you use the 32 bit fpcupdeluxe, it will give you both, including GDB.
This is also the recommended way on Windows.

So, just install once with 32 bit version and get both.

At the moment, I am testing a win 64bit install to try to reproduce your previous setup.
(64 -> 32)

MementoMojito

  • Jr. Member
  • **
  • Posts: 57
Re: Fpcupdeluxe
« Reply #8 on: November 01, 2016, 04:55:20 pm »
@MementoMojito
sudo apt-get install subversion

Thanks! I feel slightly stupid tho but it should be on the Wiki...

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Re: Fpcupdeluxe
« Reply #9 on: November 01, 2016, 04:58:45 pm »
@MementoMojito
No worries ... in due time, I will add a usermanual / help !

TheWolf

  • New member
  • *
  • Posts: 26
Re: Fpcupdeluxe
« Reply #10 on: November 01, 2016, 05:08:49 pm »
I tried to install trunk both FPC+Lazarus but Application crashes after downloading fpc. Tryed on Ubuntu 16.04 64Bit. Tested several times.
« Last Edit: November 01, 2016, 05:11:07 pm by TheWolf »

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Re: Fpcupdeluxe
« Reply #11 on: November 01, 2016, 05:21:10 pm »
Would you mind posting a screen-dump, or something else that indicates the error ?

TheWolf

  • New member
  • *
  • Posts: 26
Re: Fpcupdeluxe
« Reply #12 on: November 01, 2016, 05:22:40 pm »
thats the Error
(fpcupdeluxe-x86_64-linux:11872): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()
Speicherzugriffsfehler (Speicherabzug geschrieben)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Re: Fpcupdeluxe
« Reply #13 on: November 01, 2016, 07:15:27 pm »

DonAlfredo

  • Hero Member
  • *****
  • Posts: 769
Re: Fpcupdeluxe
« Reply #14 on: November 01, 2016, 08:22:57 pm »
@TheWolf
Just ran a test on Arch Bang 64 bit. All greens and a working FPC and Lazarus trunk.
Did you choose a special option ?

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus