Forum > General

[SOLVED] Lazarus doesn't work on VirtualBox (Windows 7 64-bit, Ubuntu as host)


Hey there!
My machine is currently running Ubuntu 16.04. I've got a VirtualBox machine with Windows 7 64-bit on it because I wanted to cross-compile my program for this platform. Unfortunately, after installing it does not work, the code is not displayed as before, it looks like the text editor one... I can't edit it and I can't even run the application, since when I press the Run button it displays the classic "Oops the debugger entered the error state" and so on...
What can I do? Here are two screenshots :) thank you in advance!

Almost all my Lazarus's run on virtualbox and I do not recognize the problem.
I have seen that message btw. In my case it was a stray gdb.
What EXACT version of fpc and what EXACT version of Lazarus are you using? And can you give us some code instead of an image that reproduces the issue?

Lazarus: 1.6
FPC: 3.0.0  :)

Error message

The GDB command
returned the error
,msg=Error creating process CUsersCiroDesktopGinoproject1.exe, (error


SOLVED! I just had to uninstall lazarus and its file on AppData, reinstall it and setting the IDE folder as C:\lazarus!!  :D  I feel so dummy

No you are not dumb. The lazarus installer and toolchain should obey Windows default install paths for executables but it doesn't (Well, lazarus does, but some of the toolchain can't wortk with paths that include spaces.)
This is a known issue and should have been solved years ago.

One way of solving it is to create an empty  directory in a path without spaces and create a symlink, junction or hardlink to the path with the spaces that includes the binutils  ;) NTFS only. Although SUBST can be used too ;)
The other way is to add a (about 10 lines of code) LongPathToShortPath utility to pipe the directories in their 8.3 form (both fats and ntfs) before calling out to the utilities that do not support long path names.

Both of these options are tasks for the maintainers. Not your fault.


[0] Message Index

Go to full version