* * *

Author Topic: app not run  (Read 1526 times)

copen

  • Newbie
  • Posts: 4
app not run
« on: July 15, 2016, 06:04:20 pm »
Hello,
My app runs on OS windows, but not on mobile pc with OS Windows Embedded handheld 6.5 professional, CE OS 5.2.29344, processor TI Cortex-A9.

I have installed Lazarus-1.6.0-fpc-3.0.0-win32 - Lazarus-1.6.0-fpc-3.0.0-cross-arm-wince ..
options -Twince -Parm -Cp(predefinito, the only accepted).

The app not runs, it is only a form with a button

Handoko

  • Hero Member
  • *****
  • Posts: 1004
  • My goal: build my own game engine using Lazarus
Re: app not run
« Reply #1 on: July 15, 2016, 07:16:01 pm »
To be able to generate code to run on WinCE, you also need to rebuild your Lazarus with WinCE Widget. Have you done it?

I'm not a WinCE user, hope this link may help:
http://wiki.lazarus.freepascal.org/Windows_CE_Interface

copen

  • Newbie
  • Posts: 4
Re: app not run
« Reply #2 on: July 18, 2016, 10:19:13 am »
I have rebuild , and also "repulish and rebuld", but nothing is changed.

Handoko

  • Hero Member
  • *****
  • Posts: 1004
  • My goal: build my own game engine using Lazarus
Re: app not run
« Reply #3 on: July 18, 2016, 12:35:59 pm »
I have rebuild , and also "repulish and rebuld", but nothing is changed.

Have you installed WinCE Widgetset?

I'm not really sure, but I think you maybe have not installed WinCE LCL Widget type properly. Please see the attached image. To do it: goto Lazarus main menu > Tools > Configure Build Lazarus. For more information, you can look at this link (see the bottom-most "Using Lazarus" topic):
http://wiki.lazarus.freepascal.org/User:CCRDude

copen

  • Newbie
  • Posts: 4
Re: app not run
« Reply #4 on: July 18, 2016, 12:58:59 pm »
No, I haven't configured; now I have configured as image, but I have errors, I attach image

Handoko

  • Hero Member
  • *****
  • Posts: 1004
  • My goal: build my own game engine using Lazarus
Re: app not run
« Reply #5 on: July 18, 2016, 04:23:28 pm »
Nothing more I can help. I tried to build WinCE LCL Widget, but failed.

According to the link I gave you, it mentions that Windows is the prerequisites to build the WinCE tutorials. I use Linux, perhaps that explain why I failed. Hope some WinCE experts will step in to help you.

Handoko

  • Hero Member
  • *****
  • Posts: 1004
  • My goal: build my own game engine using Lazarus
Re: app not run
« Reply #6 on: July 19, 2016, 04:55:42 am »
No, I haven't configured; now I have configured as image, but I have errors, I attach image

If you can't use WinCE Widgetset, you may try fpGUI widget. On its website, it says it support WinCE. Here is the link:
http://fpgui.sourceforge.net/index.shtml

Kelsey

  • Newbie
  • Posts: 2
Re: app not run
« Reply #7 on: April 26, 2017, 04:34:09 pm »
You've probably fixed this issue, but for future users looking to this post for answers, I'll still post.

I have no issues compiling applications for WinCE using Lazarus, but I have never been able to build Lazarus with the WinCE widgetset. (It gives the error pictured above.)
The following options are what I change to be able to compile applications:
Project Options -> Compiler Options -> Config and Target -> Target OS -> WinCE
Project Options -> Compiler Options -> Config and Target -> Target CPU family -> arm
(I do not have a target processor selected.)
Project Options -> Compiler Options -> Additions and Overrides -> Set "LCLWidgetType" -> WinCE
In the Additions and Overrides screen, ensure that the checkboxes next to the "LCLWidgetType:=wince" are all selected, and if there are any checkboxes for another widget type, uncheck those.

This allows me to compile for WinCE and run the exe on the device

Handoko

  • Hero Member
  • *****
  • Posts: 1004
  • My goal: build my own game engine using Lazarus
Re: app not run
« Reply #8 on: April 26, 2017, 05:53:03 pm »
Thanks for sharing the information.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus