* * *

Author Topic: [ SOLVED ] Make does not know how to build source files not found  (Read 1294 times)

matfanjol

  • Newbie
  • Posts: 2
Hello to everybody,
I need to build a modified version of FPC 2.6.4 so I have downloaded the /fpc/tags/release_2_6_4 svn tree, done my changes and started the build.
During the build that I start via
make all OS_TARGET=win32 CPU_TARGET=i386
I get errors like the following
Code: Text  [Select]
  1. make[7]: Entering directory `C:/Temp/fpc/rtl/win32'
  2. ...
  3. C:/Temp/itosac_installer/32bit/fpc/ppc386.exe -Ur -Xs -O2 -n -Fi../inc -Fi../i386 -Fi../win -FE. -FUC:/Temp/fpc/rtl/units/i386-win32 -di386 -dRELEASE ../inc/macpas.pp
  4. make[7]: *** No rule to make target `iso7185.ppu', needed by `fpc_units'.  Stop.
  5. make[7]: Leaving directory `C:/Temp/fpc/rtl/win32'
  6. make[6]: *** [win32_all] Error 2
  7. make[6]: Leaving directory `C:/Temp/fpc/rtl'
  8. make[5]: *** [rtl] Error 2
  9. make[5]: Leaving directory `C:/Temp/fpc/compiler'
  10. make[4]: *** [next] Error 2
  11. make[4]: Leaving directory `C:/Temp/fpc/compiler'
  12. make[3]: *** [ppc1.exe] Error 2
  13. make[3]: Leaving directory `C:/Temp/fpc/compiler'
  14. make[2]: *** [cycle] Error 2
  15. make[2]: Leaving directory `C:/Temp/fpc/compiler'
  16. make[1]: *** [compiler_cycle] Error 2
  17. make[1]: Leaving directory `C:/Temp/fpc'
  18. make: *** [build-stamp.i386-win32] Error 2
  19.  

I have looked at the Makefile and it is correct: there are no indications about how to build the iso7185, but if I copy the rtl\inc files (where iso7185.pp is) inside the compiling directory rtl\win32 it builds it and it goes on.
So, I think there is something missing in my environment.
If I do that manual copy, the compilation goes on, but later I will get errors on packages\hash, packages\pasjpeg, etc. and in those cases it works copying the src files (i.e. copying packages\hash\src inside packages\hash).
I have tried to change or force some -Fi, -Fl, -Fu and -I parameters providing the src, win, inc folders (with .., ..\.., etc.) but without success.

Any suggestions about how to be able to build it without copying the files manually?

Thanks!
« Last Edit: July 03, 2016, 09:57:27 am by matfanjol »

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5641
Re: Make does not know how to build source files not found
« Reply #1 on: July 02, 2016, 11:46:04 pm »
Usually such behaviour is due conflicting tool chains in the path.

Try to put just the  FPC dir and windows dirs in the %PATH%.

matfanjol

  • Newbie
  • Posts: 2
[ SOLVED ] Re: Make does not know how to build source files not found
« Reply #2 on: July 03, 2016, 09:57:05 am »
Hello MarcoV,
I have tried it, but without success.

I have solved it few minutes ago: the problem is the compiler.
I have successfully compiled FPC 2.6.4 compiling it with FPC 2.6.0, the only working.
After the successfull compilation, I have compiled it again with the new FPC 2.6.4 and everything is fine.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus