* * *

Author Topic: <SOLVED> Lazarus 1.6 and LNet  (Read 6501 times)

JZS

  • Full Member
  • ***
  • Posts: 167
<SOLVED> Lazarus 1.6 and LNet
« on: February 20, 2016, 06:54:13 pm »
Is there anyone succeeded on installing LNet under The newly released Lazarus 1.6?

I have got an error in unit fphttpclient at uses sslsockets; with the message:
Cannot find sslsockets used by fphttpclient. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=…

Is there anything changed? This did not happen in RC2.
« Last Edit: February 21, 2016, 10:44:18 am by JZS »
I use recent stable release

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5247
Re: Lazarus 1.6 and LNet
« Reply #1 on: February 20, 2016, 07:23:59 pm »
Did you check the "tick" that erases old configs during installation?

JZS

  • Full Member
  • ***
  • Posts: 167
Re: Lazarus 1.6 and LNet
« Reply #2 on: February 21, 2016, 07:40:02 am »
Did you check the "tick" that erases old configs during installation?

Yeap. I did.

And here is the complete message:
fphttpclient.pp(285,6) Fatal: Cannot find sslsockets used by fphttpclient. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=C:\lazarus\fpc\3.0.0\units\i386-win32\fcl-net\sslsockets.ppu..

PS: I am using Lazarus 1.6 on Win 8
I use recent stable release

JZS

  • Full Member
  • ***
  • Posts: 167
Re: Lazarus 1.6 and LNet
« Reply #3 on: February 21, 2016, 08:32:09 am »
And BTW this has happened on two different installation (two pc's both Win 8 ) I end up with the the same error message.

Seems that there is an issue with the package WebLaz, apparently LNet uses some (SSL units) from WebLaz and hence it invokes that error while installing. So now the question is, anyone is able to install WebLaz successfully on Lazarus 1.6?
« Last Edit: February 21, 2016, 08:38:35 am by JZS »
I use recent stable release

Jurassic Pork

  • Hero Member
  • *****
  • Posts: 597
Re: Lazarus 1.6 and LNet
« Reply #4 on: February 21, 2016, 08:46:47 am »
hello,
no problem with Lazarus 1.6RC1 32 bits win7  and lnet 0.6.5 :
compile and install lnetvisual package ( this install lnetbase package)


Friendly, J.P



JZS

  • Full Member
  • ***
  • Posts: 167
Re: Lazarus 1.6 and LNet
« Reply #5 on: February 21, 2016, 08:58:43 am »
Hi J.P

There was no problem in RC1 nor RC2, it only appeared in the recent release of 1.6!!!
I use recent stable release

TraumTaenzerDieter

  • New member
  • *
  • Posts: 16
Re: Lazarus 1.6 and LNet
« Reply #6 on: February 21, 2016, 09:14:30 am »
I had the same problem, but after DELETING the complete directory
and copying the latest trunk version from here
svn.freepascal.org/svn/fpcprojects/lnet/trunk
there was no more problem.
« Last Edit: February 21, 2016, 09:16:17 am by TraumTaenzerDieter »

GetMem

  • Hero Member
  • *****
  • Posts: 1993
Re: Lazarus 1.6 and LNet
« Reply #7 on: February 21, 2016, 09:20:14 am »
@JZS
Works fine with trunk.

JZS

  • Full Member
  • ***
  • Posts: 167
Re: Lazarus 1.6 and LNet
« Reply #8 on: February 21, 2016, 09:36:33 am »
Still the same error, when I tried the LNet trunk 2661 with the SR 1.6!!! I do not know why but I see the problem coming from the SSL units of the WebLaz.

Any one tried to install WebLaz and/or LNet on the SR 1.6?
I use recent stable release

JZS

  • Full Member
  • ***
  • Posts: 167
Re: Lazarus 1.6 and LNet
« Reply #9 on: February 21, 2016, 09:43:45 am »
Still the same error, when I tried the LNet trunk 2661 with the SR 1.6!!! I do not know why but I see the problem coming from the SSL units of the WebLaz.

Any one tried to install WebLaz and/or LNet on the SR 1.6?

False Alarm...

Forgot to Uninstall/delete package links of the LNet 6.5 before installing the trunk.

I confirm the trunk 2661 works OK as well as WebLaz.

Thank you all...
I use recent stable release

dailton

  • New member
  • *
  • Posts: 30
Re: <SOLVED> Lazarus 1.6 and LNet
« Reply #10 on: July 22, 2016, 04:52:52 pm »
Hi,

I'm still having the same problem using Lazarus 1.6 Win32, Win8, trunk 2702.

Can anybody help?

Thanks in advance.

Dailton

technipixel

  • Full Member
  • ***
  • Posts: 213
    • TechniPixel Solutions
Re: <SOLVED> Lazarus 1.6 and LNet
« Reply #11 on: August 18, 2016, 05:21:55 pm »
Having the same problem.
Someone needs to add FTP functionality into LAZ as a default control or functions and do away with Indy, Inet and synapse
I read about way too many issues installing or linking with LAZ

"Just saying"  %)
Lazarus 1.6 w/FPC-3.0 • Windows 7 • 10G RAM • NIV-GForce GT 640 Graphics Card
Newbie coming from VB6, VBA, .NET (C# & VB)
Other languages: sql, php, html, CSS, javascript, actionscript.

wp

  • Hero Member
  • *****
  • Posts: 3344
Re: <SOLVED> Lazarus 1.6 and LNet
« Reply #12 on: August 18, 2016, 07:01:41 pm »
I just tried it with Laz 1.6, LNet 2702, Win 10 - no problem.

@technipixel: From your question in the other thread  (http://forum.lazarus.freepascal.org/index.php/topic,33720.msg219062/topicseen.html#new) I suspect that you did not install the package correctly. In case of LNet you have two packages, lnetbase.lpk and lnetvisual.lpi. You definitely must "Compile" (see my post in the other thread) the lnetbase package. If you want the designtime components on the component palette you must alse "Use/Install" the lnetvisual package.
Lazarus trunk / fpc 3.0.0 / Win32

engine32

  • Newbie
  • Posts: 3
Re: <SOLVED> Lazarus 1.6 and LNet
« Reply #13 on: January 29, 2017, 05:38:42 am »
I have same problem after one year 1.6 was released. How you "install from trunk" ? Where I can find trunk 2661 ? It is so frustrating.. I tried everything, including uninstalling Lazarus and cleaning everything about it.

GetMem

  • Hero Member
  • *****
  • Posts: 1993
Re: <SOLVED> Lazarus 1.6 and LNet
« Reply #14 on: January 29, 2017, 08:46:09 am »
@engine32
Quote
I have same problem after one year 1.6 was released. How you "install from trunk" ? Where I can find trunk 2661 ? It is so frustrating.. I tried everything, including uninstalling Lazarus and cleaning everything about it.
Try the one from the Online Package Manager, it works with Lazarus 1.6(just tested).

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus