* * *

Author Topic: Totally confused: "Cannot find unit gettext"  (Read 8584 times)

GetMem

  • Hero Member
  • *****
  • Posts: 2937
Re: Totally confused: "Cannot find unit gettext"
« Reply #15 on: December 19, 2015, 12:11:55 pm »
@Thaddy
Ubuntu 14.04 LTS(see attachments):

mikea105

  • New member
  • *
  • Posts: 14
Re: Totally confused: "Cannot find unit gettext"
« Reply #16 on: December 20, 2015, 07:02:54 am »
 :o
Everything is now a total dog's breakfast.  After deleting the files in the list and the gettext directory, I somehow managed to thrash the operating system.  It will now boot only into terminal mode, and I have no idea where to go from here.  I found a page that talked about how to fix nvidia driver problems (which I fixed before), but now the nvidia-detect program won't run, even though I used apt-get remove and then apt-get install for it.  apt-get says it worked fine installing it, but the program simply won't run.

And it's constantly complaining about wanting me to install fpc. 

I got desperate enough to start to reinstall Mint, but the installer keeps bitching about not having a root.  I finally got it to set the mount point to the root of the drive where Mint is installed, and then it says it's going to delete the whole system (and possibly everything else) when I reinstall it and asks if everything is backed up.  I aborted the reinstall.  I don't know what to do now.  No idea at all.  Don't even know if I can save my data.   

I'm too ignorant of Linux to know how to fix this or to dare to mess around with it on my own because I'm sure I'll just destroy my email archives, documents and everything else.  (I'm wondering if I can save those somehow.)  This started as a glitch with lazarus and is now a death spiral for my whole Linux install.  Does anyone have any ideas on how I might be able to save anything?  I'd like to at least save my working files and email archives.  Ideally, I'd like to get Mint working again.  I might even be brave enough to try Lazarus again if I manage to save my data somehow.  I've used Mint for several months now, and it's been great -- until this nightmare started.  Can anyone help?

mikea105

  • New member
  • *
  • Posts: 14
[SOLVED] Totally confused: "Cannot find unit gettext"
« Reply #17 on: December 24, 2015, 05:27:38 am »
Okay, I think this is as solved as it's going to be.  I ended up having to use the nuclear option  >:D   Not only formatted the drive, but had to use gparted to delete the partition because the installer wouldn't work otherwise.

Fortunately, I was able to boot with a DVD and copy my home directory off beforehand, so although it's going to be a pain to bring the computer back to where it was, at least it's possible, eventually.

Thanks to everyone who posted for their help!

 :)

VincePelss

  • Newbie
  • Posts: 1
Re: Totally confused: "Cannot find unit gettext"
« Reply #18 on: November 11, 2017, 02:16:40 am »
Okay, I did what you said, and here's everything (using "copy all/original messages to clipboard") from the message window. 

Hint: (11030) Start of reading config file /home/fred/.fpc.cfg
Hint: (11031) End of reading config file /home/fred/.fpc.cfg
Free Pascal Compiler version 2.6.4 [2014/04/20] for x86_64
Copyright (c) 1993-2014 by Florian Klaempfl and others
(1002) Target OS: Linux for x86-64
(3104) Compiling /home/fred/tmp/project1.lpr
Fatal: (10022) Can't find unit gettext used by LazUTF8
Fatal: (1018) Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)

Does this help?  I'm at my wit's end (a short trip, I admit).  I've tried uninstalling everything several times.  I've tried installing the older version in Synaptic.  That one won't even pretend to work.  Then I got rid of that and put back version 2.6.4 which this is.  It works fine -- until I try to compile.  I can't begin to imagine what is going on here.  Is there some other set of code/method of installation I can try?  I really have no idea what to do now.  I had Lazarus working once, and it worked fine until something broke, and now I can't even try to compile my partly finished program any more.  It it looks like all the work I did was for nothing.   :'(

Any ideas from anyone would REALLY be appreciated.  How can I get this damn thing to run?  If it helps, I'm using Mint Rafaela.

This happened to me.

My solution was to delete the equivalent file below:
home/fred/.fpc.cfg

Handoko

  • Hero Member
  • *****
  • Posts: 2161
  • My goal: build my own game engine using Lazarus
Re: Totally confused: "Cannot find unit gettext"
« Reply #19 on: November 11, 2017, 04:13:57 am »
Sometimes simply deleting fpc.cfg is not enough. For example I tried to combine Lazarus with FPC version that not compatible, it ended with buggy result.

The fix it, I need only to do a complete Lazarus/FPC removal. Read more (see the detail of step #1):
http://forum.lazarus.freepascal.org/index.php/topic,38828.msg265293.html#msg265293

My solution has never failed so far.

BBasile

  • Sr. Member
  • ****
  • Posts: 391
Re: Totally confused: "Cannot find unit gettext"
« Reply #20 on: November 11, 2017, 11:05:58 am »
The error message: "Cannot find unit ..."  can happen for two reasons:
  1. The file is missing
  2. The file is present but it's the wrong version

Exactly looks like something that could be indicated in a better error message (even w/o elevated verbosity), particularly since the question comes often.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus