* * *

Author Topic: suggest : disable DPI Awareness for IDE  (Read 1564 times)

baldzhang

  • New member
  • *
  • Posts: 9
suggest : disable DPI Awareness for IDE
« on: December 10, 2015, 10:14:47 pm »
I just got a new notebook with 4K display and do some testing.

The lazarus IDE itself is not suitable for high DPI yet.
then I uncheck the DPI Awareness checkbox and rebuild the IDE, now everything looks fine.

I also check PixelPerInch in object-inspector for the default form, it is 96. I think is a reasonable value for development.

Shall I create a bug report for this ?


Looks like I post in wrong place, someone please move it to proper place.
« Last Edit: December 10, 2015, 10:34:25 pm by baldzhang »

regs

  • New member
  • *
  • Posts: 42
Re: suggest : disable DPI Awareness for IDE
« Reply #1 on: July 27, 2016, 05:28:42 pm »
Somehow this doesn't work for me. Tryed check, uncheck dpi awareness in compatibility, it still forces api awareness. Lazarus 1.6. Removing manifest and recompiling doesn't help as well. Looks like it forces it somewhere else?
« Last Edit: July 27, 2016, 05:49:54 pm by regs »

regs

  • New member
  • *
  • Posts: 42
Re: suggest : disable DPI Awareness for IDE
« Reply #2 on: July 27, 2016, 08:27:56 pm »
Removed manifest, recompiled without it and now it scales proportionally. All blurry of course, but at least can design forms at 96 dpi and toolbars are visible.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus