* * *

Author Topic: Lazarus 1.6 - 1st Release Candidate  (Read 35248 times)

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 3955
    • wiki
Lazarus 1.6 - 1st Release Candidate
« on: December 08, 2015, 05:29:35 pm »
The Lazarus team is glad to announce the first release candidate of Lazarus 1.6.

This release was built with FPC 3.0.0.
The previous release Lazarus 1.4.4 was built with FPC 2.6.4.

Here is the list of fixes for Lazarus 1.6:
http://wiki.freepascal.org/Lazarus_1.6_fixes_branch

Here is the list of changes for Lazarus and Free Pascal:
http://wiki.lazarus.freepascal.org/Lazarus_1.6.0_release_notes
http://wiki.lazarus.freepascal.org/User_Changes_3.0.0

The release is available for download on SourceForge:
http://sourceforge.net/projects/lazarus/files/

Choose your CPU, OS, distro and then the "Lazarus 1.6RC1" directory.

Minimum requirements:

Windows:       
  98, 2k, XP, Vista, 7, 32 or 64bit.
  Win98 and WinNT IDE needs FPC 2.6.4 and building with flag -dWIN9XPLATFORM.
               
FreeBSD/Linux:
  gtk 2.8 or qt4.5, 32 or 64bit.

Mac OS X:
  10.5 to 10.11, LCL only 32bit, non LCL apps can be 64bit.

The svn tag is
http://svn.freepascal.org/svn/lazarus/tags/lazarus_1_6_RC1

== Why should everybody (including you) test the release candidate? ==

In the past weeks the Lazarus team has stabilized the 1.6 fixes branch. The resulting 1.6RC1 is now stable enough to be used by any one for test purposes.

However many of the fixes and new features that where committed since the release of 1.4 required changes to the code of existing features too. While we have tested those ourself, there may still be problems that only occur with very specific configurations or one project in a million.

Yes, it may be that you are the only person with a project, that will not work in the new IDE. So if you do not test, we can not fix it.

Please do not wait for the final release, in order to test. It may be too late. Once the release is out we will have to be more selective about which fixes can be merged for further 1.6.x releases. So it may be, that we can not merge the fix you require. And then you will miss out on all the new features.

== How to test ==

Download and install the 1.6RC1.
- On Windows you can install as a 2ndary install, that will not affect your current install:
  http://wiki.lazarus.freepascal.org/Multiple_Lazarus#Installation_of_multiple_Lazarus
- On other platforms, if you install to a new location you need to use --primary-config-path

In either case you should make backups. (including your primary config)

Open your project in the current Lazarus (1.4.x), and use "Publish Project" from the project menu. This creates a clean copy of your project.

You can then open that copy in the RC1. Please test:
- If you can edit forms in the designer
   - rename components / change properties in Object inspector / Add new events
   - Add components to form / Move components on form
   - Frames, if you use them
- If you can navigate the source code (e.g. jump to implementation)
- Auto completion in source code
- Compile, debug and run
- Anything else you use in your daily work



Deepaak

  • Sr. Member
  • ****
  • Posts: 356
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #1 on: December 08, 2015, 05:37:11 pm »
Amazing.. I was really waiting for it. great works team Lazarus  :)
Ooops Holiday season is offline now.

JD

  • Hero Member
  • *****
  • Posts: 1377
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #2 on: December 08, 2015, 05:39:52 pm »
I've been waiting for this since like forever. Finally I can try FPC 3.0! Well done! Thanks a lot!

JD
Windows (10, 7) - Lazarus 1.6/FPC 3.0 (also Delphi occasionally)
Linux Mint Cinnamon  - Lazarus 1.4/FPC 2.6.4
Indy 10.6 series; Zeos 7.2.1; SQLite, Firebird, PostgreSQL & MariaDB

Segator

  • New member
  • *
  • Posts: 26
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #3 on: December 08, 2015, 09:07:30 pm »
Very good news, i wait for this release after that the fpc 3.0 was released.

Segator

  • New member
  • *
  • Posts: 26
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #4 on: December 08, 2015, 09:27:22 pm »
I read the change log of this RC1, congratulations for the Lazarus team, but i have a question, i not found any progress with GTK3 and QT5 widgetsets, exists any plan to support this?, GTK3 is in alpha state i now but, is not are plans respect to this for the future?.

bigeno

  • Full Member
  • ***
  • Posts: 169
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #5 on: December 08, 2015, 10:56:02 pm »
waiting for win x64 compilation

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 3955
    • wiki

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 3955
    • wiki
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #7 on: December 08, 2015, 11:29:18 pm »

BBasile

  • Full Member
  • ***
  • Posts: 174
    • my GitHub
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #8 on: December 09, 2015, 02:27:46 am »
Do Laz and fpc rpms support the --prefix option ?

BBasile

  • Full Member
  • ***
  • Posts: 174
    • my GitHub
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #9 on: December 09, 2015, 02:33:10 am »
actually it seems that they're not (rpm -qi <name> on the previous one), how can I setup in my home ?

fic

  • New member
  • *
  • Posts: 14
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #10 on: December 09, 2015, 03:11:59 am »
Well, I've found my first bug :-(

Trying to doubleClick on the form's event OnDestroy gives me an error : Unable to find method.
lclclasses.pp(26,10) : Error : unit classes not found

This seems to be the case as well when I doubleclick the OnClick-event of a button...

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 3955
    • wiki
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #11 on: December 09, 2015, 03:20:49 am »
Trying to doubleClick on the form's event OnDestroy gives me an error : Unable to find method.
lclclasses.pp(26,10) : Error : unit classes not found

Is that a new install or an update?

If you updated without uninstall, then check that fpc source points to 3.0 (since your old install did probably have 2.6.4)

In any case, even if it points to 3.0 it there may be some caches still based on 2.6.4 .
Menu Tools "rescan fpc source direrctory"


fic

  • New member
  • *
  • Posts: 14
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #12 on: December 09, 2015, 03:28:44 am »
It was an update, and I just did the rescan of the fpc directory as you suggested. And that helped  :D
Thank you!

frakno

  • Jr. Member
  • **
  • Posts: 79
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #13 on: December 09, 2015, 04:58:52 pm »
Thank you very much. Some nice improvements.

When I install Internet packages - such as internet tools or LNet -
I get a warning: Recompiling sslsockets, checksum changed for OpenSSL
         and Fatal: Can not find sslsockets used by fphttpclient.

Can you help
Lazarus 1.6 FPC 3.0 Windows 10

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 3955
    • wiki
Re: Lazarus 1.6 - 1st Release Candidate
« Reply #14 on: December 09, 2015, 05:20:09 pm »
Thank you very much. Some nice improvements.

When I install Internet packages - such as internet tools or LNet -
I get a warning: Recompiling sslsockets, checksum changed for OpenSSL
         and Fatal: Can not find sslsockets used by fphttpclient.

That would be a problem in that package. Caused by circular unit references combined with some other feature, such as maybe inline.

Either:

1) Try to compile with inline disabled.

2) Open the package, and build it alone, repeat without making changes (1 or 2 repeats). The first build can be "build clean", but after that no "clean" anymore.
After that make sure not to change any settings, so it does not need any recompilation.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus