* * *

Author Topic: Lazarus 1.0 release candidate 2 available for download  (Read 36256 times)

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2653
    • My Lazarus wiki user page
Lazarus 1.0 release candidate 2 available for download
« on: August 22, 2012, 12:46:30 pm »
The Lazarus team is glad to announce that Lazarus 1.0RC2 is available for download at the SourceForge download page:
http://sourceforge.net/projects/lazarus/files/

Choose your CPU / OS / distro and then the 1.0RC2 directory.

Minimum requirements:
Windows:       98, 2k, XP, Vista, 7, 32 or 64bit
FreeBSD/Linux: gtk 2.8 or qt4.5, 32 or 64bit
Mac OS X:      10.4, LCL only 32bit, non LCL apps can be 64bit

This release has been built with fpc 2.6.0 (the former release 0.9.30.4 was
built with that too).

The svn tag is
http://svn.freepascal.org/svn/lazarus/tags/lazarus_1_0_RC2

The list of changes:
http://wiki.lazarus.freepascal.org/Lazarus_1.0_release_notes

For people who are blocked by SF, the Lazarus releases from SourceForge are mirrored at:
ftp://freepascal.dfmk.hu/pub/lazarus/releases/
http://michael-ep3.physik.uni-halle.de/Lazarus/releases/
http://mirrors.iwi.me/lazarus/

Please, let me know if you find any problems with these release candidates.

Also let me know if you installed it without any problem.
« Last Edit: August 22, 2012, 01:00:27 pm by Vincent Snijders »

tintinux

  • Full Member
  • ***
  • Posts: 146
    • Gestinux
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #1 on: August 22, 2012, 06:58:57 pm »
Hi

Thanks and specially for the new ReadMe.txt, saving our time !
Could you also please add a note in some of the hardware nodes, to explain shortly to dummies like me the exact meanings of i386, amd64 et c...
It is not obvious to select amd when you know you have an intel processor.

When we try to "execute" the fpc_2.6.0-120728_amd64.deb  on Ubuntu 12.04 (and probably others), we get a warning saying "the package is of bad quality.  The package doesn't provide a valid Installed-Size control field. See Debian Policy 5.6.20."
I know this should not be a true issue, but It would be better to correct this...
 
Regards
Author of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

I need help for translations, and to provide examples of legal charts and reports for more countries.

wylton

  • New member
  • *
  • Posts: 27
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #2 on: August 23, 2012, 10:29:03 am »
does it soport ruta with unicode  like /españa/中文/english?

motaz

  • Sr. Member
  • ****
  • Posts: 418
    • http://code.sd
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #3 on: August 23, 2012, 11:22:58 am »
Downloaded and tested successfully in Linux Mint 32 bit.

Mirrors for people who blocked by source forge is greatly appropriated

JD

  • Hero Member
  • *****
  • Posts: 1038
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #4 on: August 23, 2012, 12:24:51 pm »
Downloaded and tested successfully in Linux Mint 32 bit.

Mirrors for people who blocked by source forge is greatly appropriated

Wow! I really feel for you because of the restrictions (i.e blocked sites) you have to live with just because you live in Sudan. It is completely ridiculous. I wonder if it is the same with Chinese Lazarus users.
Windows (Vista, 7) - Lazarus 1.2.2/FPC 2.6.4 (also Delphi 2010 and 2006 once in a while)
Linux Mint - Lazarus 1.2.2/FPC 2.6.4
Indy 10.6 series; Zeos 7.1.3; SQLite, Firebird, PostgreSQL & MariaDB

motaz

  • Sr. Member
  • ****
  • Posts: 418
    • http://code.sd
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #5 on: August 23, 2012, 12:56:41 pm »
SF is not blocked from Sudan, but SF is blocking Sudanese from downloading software by default, but not all software in SF are blocked, for instance we can download FireBird from SF. I think Lazarus team could change this default restriction and enable us to download Lazarus from there.

Most of US companies are blocking us to access their sites like Embarcadero, Oracle, Google, except Microsoft, we can download anything from Microsoft site, I don't know why.

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2653
    • My Lazarus wiki user page
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #6 on: August 23, 2012, 01:04:13 pm »
The Lazarus team cannot change this restriction unless it falsely claims that
Quote
This project does NOT incorporate, access, call upon, or otherwise use encryption of any kind, including, but not limited to, open source algorithms and/or calls to encryption in the operating system or underlying platform.

The windows installers include units offered by the fpc team, which among others, contains the blowfish unit.

NelsonN

  • Jr. Member
  • **
  • Posts: 53
    • 3D Librarian
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #7 on: August 23, 2012, 02:09:09 pm »
After installing Free Pascal I get this error when I try to install Lazarus RC2:

error: Failed dependencies:
   fpc = 2.6.0-2.fc17 is needed by lazarus-1.0RC2-0.i386

I installed Free Pascal as I always do and didn't have this problem when I installed RC1.

I installing on OpenSuse 12.1.

gypsymauro

  • Newbie
  • Posts: 2
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #8 on: August 23, 2012, 02:34:51 pm »
In the changelog you say:

SQLDB

    Added mssql connectors (supports Microsoft SQL Server), requires fpc 2.6.1+
    Added sybase connectors (supports Sybase ASE), requires fpc 2.6.1+
    Added mysql 5.5 connector, requires fpc 2.6.1+

but on debian 64 bit RC2 has not those connectors :( is available just for windows? there is a freetds implementation for linux too,
any hint?

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2653
    • My Lazarus wiki user page
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #9 on: August 23, 2012, 03:10:08 pm »
Those connectors are only available if compiled with fpc 2.6.1 and later.

From the announcement:
Quote
This release has been built with fpc 2.6.0 (the former release 0.9.30.4 was
built with that too).

So you can get those connectors, if you use a fpc development version.

cpalx

  • Sr. Member
  • ****
  • Posts: 477
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #10 on: August 23, 2012, 04:48:00 pm »
there exists a bug in lazreport (0022506) i cant image a release version without fix that bug.

airpas

  • Full Member
  • ***
  • Posts: 108
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #11 on: August 24, 2012, 10:20:39 am »
good release its much stable

in your TODO list arn't there intention to make lazarus looks like delphi now days , the idea of separate windows like delphi7 is ok , but the new look of delphi now days  (all in one window) is much better .

good luck

mariuz

  • New member
  • *
  • Posts: 26
    • http://flamerobin.org
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #12 on: August 24, 2012, 11:36:26 am »
Hi

Thanks and specially for the new ReadMe.txt, saving our time !
Could you also please add a note in some of the hardware nodes, to explain shortly to dummies like me the exact meanings of i386, amd64 et c...
It is not obvious to select amd when you know you have an intel processor.

When we try to "execute" the fpc_2.6.0-120728_amd64.deb  on Ubuntu 12.04 (and probably others), we get a warning saying "the package is of bad quality.  The package doesn't provide a valid Installed-Size control field. See Debian Policy 5.6.20."
I know this should not be a true issue, but It would be better to correct this...
 
Regards
I have added my i386 and amd64 notices for Ubuntu on my blog maybe i should copy paste some of them in the readme

http://mapopa.blogspot.ro/2012/08/lazarus-10-release-candidate-2.html
« Last Edit: August 24, 2012, 02:32:51 pm by mariuz »

mattias

  • Administrator
  • Jr. Member
  • *
  • Posts: 67
    • http://www.lazarus.freepascal.org
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #13 on: August 24, 2012, 11:58:22 am »
After installing Free Pascal I get this error when I try to install Lazarus RC2:

error: Failed dependencies:
   fpc = 2.6.0-2.fc17 is needed by lazarus-1.0RC2-0.i386

I installed Free Pascal as I always do and didn't have this problem when I installed RC1.

I installing on OpenSuse 12.1.

Sorry. My fault. I built the rpm on a machine with the fc17 fpc rpm.
I uploaded a new Lazarus rpm that was built with the fpc rpm from sf. Please test.

NelsonN

  • Jr. Member
  • **
  • Posts: 53
    • 3D Librarian
Re: Lazarus 1.0 release candidate 2 available for download
« Reply #14 on: August 24, 2012, 02:34:37 pm »
Sorry. My fault. I built the rpm on a machine with the fc17 fpc rpm.
I uploaded a new Lazarus rpm that was built with the fpc rpm from sf. Please test.

Thanks.

But, I used the --nodeps switch when installing Lazarus and it installed and works fine.

I, also, did install the Ubuntu .debs and they installed fine.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus