* * *

Author Topic: sqlite3laz0.4 not work at Win7  (Read 4584 times)

Tango

  • Newbie
  • Posts: 1
sqlite3laz0.4 not work at Win7
« on: April 23, 2011, 07:20:32 pm »
Good day together

Hello community, I try to

Package -> Configure installed package

The package sqlite3laz0.4 - to> Install choice.
As soon as I click Save and recompile the IDE

get compile error message.

Code: [Select]
Hint: Start of reading config file c:\lazarus\fpc\2.4.2\bin\x86_64-win64\fpc.cfg
Hint: End of reading config file c:\lazarus\fpc\2.4.2\bin\x86_64-win64\fpc.cfg
Free Pascal Compiler version 2.4.2 [2011/03/30] for x86_64
Copyright (c) 1993-2010 by Florian Klaempfl
Target OS: Win64 for x64
Compiling sqlite3laz.pas
Compiling registersqlite3.pas
c:\lazarus\components\sqlite\registersqlite3.pas(1,1) Fatal: Can't find unit sqlite3ds used by registersqlite3

Lazarus used version 0.9.30 (which is currently being offered as the default for download)
Operating system Windows 7 Ultimate 64Bit
Sqlite3.dll sqlite3.def and sqlite3.exe are under Windows/system32 directory and the directory Lazarus

What am I doing wrong? or why the bundled package is not installed properly?

LuizAmérico

  • Sr. Member
  • ****
  • Posts: 346
Re: sqlite3laz0.4 not work at Win7
« Reply #1 on: April 24, 2011, 01:24:45 am »
This can be one of the following:

- The installation does not come with sqlite3ds unit (check [fpcfolder]\units\[processor-os]\fcl-db)
- Theres a source file sqlite3ds in the compiler path or the lazarus path

jacem

  • New member
  • *
  • Posts: 16
Re: sqlite3laz0.4 not work at Win7
« Reply #2 on: July 20, 2011, 10:25:20 pm »
Are you using the 32 or 64 bit version of lazarus I only got a very limited selection of DB connectors in the 64 bit version.  the others seemed to be there but would not compile. uninstalling and installing the 32 bit version seemed to help.

Jonathan

baloghsan

  • Newbie
  • Posts: 1
Re: sqlite3laz0.4 not work at Win7
« Reply #3 on: July 27, 2011, 12:37:05 pm »
I had same problem. I copied the missing files to the sqlite pack folder from the other directory. It had been compiled, but lazarus not started, because sqlite.dll missing. And no x64 sqlite.dll exist anywhere!

Solution: uninstall the x64 lazarus, and install the 32bit Lazarus. It works fine! And it has more database possibility.

If you compiled the sqlite  package (only need the squlite3) you must copy the sqlite3.dll to the lazarus directory, and to the project directory!

Takeda

  • Full Member
  • ***
  • Posts: 141
Re: sqlite3laz0.4 not work at Win7
« Reply #4 on: March 06, 2012, 08:54:15 am »
I'm so sure it is FPC Issue since it works fine for i386-Win32 but it would failed for x86_64-win64..
coz When I saw on "...\x86_64-win64\fcl-db" folder, I didn't saw both sqlite3ds.o sqlite3ds.ppu but for "...\i386-win32\fcl-db" both of SQLite3ds available inside of "...\i386-win32\fcl-db"

Note :
1. I use default FPC 2.6.0 which not compiled with Lazarus. It means, even FPC itself didn't provide SQLite3ds for x86-64_win64.
2. I test using latest Lazarus Trunk svn (at this time)..

regards,
takeda.
Call me Takeda coz that's my true name.
Pascal coding using Lazarus => "Be native in any where.."

ƪ(˘⌣˘)┐ ƪ(˘⌣˘)ʃ ┌(˘⌣˘)ʃ

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus